Migrating Survey from Enterprise to AGOL

290
1
07-07-2021 07:36 AM
BKS
by
Occasional Contributor

Hello,

Perhaps someone can help me out.

I have a perfectly functioning inspection survey operating in an ArcGIS Enterprise platform.  We have the need to migrate this to AGOL.  

The survey is based on a published FL consisting of an asset FC, a related inspection table, and attachments enabled on the inspection table.  Between each of these entities are relationship classes (RCs).  Per the S123 documentation, the relationship classes are based on GlobalID and GUID fields.  

This inspection has been in use for a little while and they have created a number of inspections.

I did the following to port it to AGOL:

Enterprise...

1) Exported FL to fGDB and downloaded as zip.  

2) Downloaded, unzipped and reviewed in ArcGIS Pro.  All looks good.

AGOL...

3) Published the FL contents to AGOL using ArcGIS Pro, Publish Web Layer

Reviewed the FL in a classic map viewer and all looked good.  I can select one asset from the table, and I can see the related inspection table record using Show (1) at end of asset table.  I can also see the inspection attachments via Show (4) at end of the inspection table.   So all relationships seem to be fine as far as I can tell.

4) Using S123 Connect, created new survey based on this FL (which I've done before but this time there is data in the FL).

5) Copied the contents of the XLS form from Enterprise into the newly created survey based on the AGOL FL (Made sure not to modify the form_id or submission URL).

6) Published the new survey with all Options checked.

7) Updated the web map and shared the survey as I always do.

I'm not 100% sure but I suspect what I have done is a reasonable approach.  If someone has a better approach (e.g. way to xfer FL from Enterprise to AGOL without exporting to fGDB please let me know).

The Problem... when I go to submit it seems to upload the survey contents and attachments but then says the following and the survey remains in the Outbox.

BKS_0-1625667626685.png

When I open up the Data tab in S123 website, I can see all of the data, HOWEVER, when I select a record n the asset table, it does NOT select any records in the inspection related table (i.e. I have the "Automatically select related records" setting checked).  

Another clue, when I have the Form View active (i.e. it shows the selected data in a rudimentary form), and I select a inspection related record, it gives me following error:

BKS_1-1625668136435.png

Any suggestions?  Next steps?

Note - Except for the fact that this FL has data in it, I've done this before and it's worked fine.  I created an empty FC, related table based on GlobalIDs and GUID and setup RC and added attachments to the related inspection table.  I published this empty dataset as a web layer and went through the steps above.  This all worked fine.  Not sure why there's an issue this time.  

Note - I have checked again in AGOL that the relationships between asset, inspection and inspection attachments appear to be working fine via Map Viewer Classic.

 

 

 

 

0 Kudos
1 Reply
JamesTedrick
Esri Esteemed Contributor

Hi @BKS ,

Based on your description, there are a few things that would help diagnose this issue:

- Create a log of the submission attempt - that will have a more detailed set of information about the failure to submit a record

- Based on the layer error message, you may want to check the table names, in the layer listing, the in the relationship definitions and the XLSX file, to make sure that everything matches.

This might be better addressed through an Esri Support call, as this may take some interactive troubleshooting, than via the Esri Community.

0 Kudos