In form view shows field name not label/alias

421
4
10-26-2022 09:55 PM
NurbekGabdullin
New Contributor

Hi Community,

Need your assistance, we mentioned that in Form View (or when you do Print), it show field names in stead of labels, but it was working well in the past. In the screenshot i have highlighted problem parts. Do you know how to show labels?123.PNG

0 Kudos
4 Replies
Alex_at_Exprodat
New Contributor II

I have found this issue appears to be due to the additional language column in the survey XLSForm. With the "label::Russian (ru)" column added for Russian-language field labels/aliases, it shows the field name rather than the label in the Form View as well as the Analysis tab.

Data tab and Form View of survey with the label::Russian (ru) column. Note that only the select_one and select_multiple types are shown with field names in the Form view. They appear correct in the table view, and other question types also appear correctly.

Alex_at_Exprodat_0-1666870718087.png

Analyze tab showing field name for select_one (and select_multiple) questions but other types show field label/alias correctly.

Alex_at_Exprodat_2-1666871086591.png

 

XLSForm showing the label::Russian (ru) column populated with placeholder values.

Alex_at_Exprodat_1-1666870850167.png

 

With the label::Russian (ru) values are removed from the XLSForm, the labels appear correctly in the Data tab table and Form view:

Alex_at_Exprodat_4-1666871284240.png

 

And appear correctly in the Analyze tab:

Alex_at_Exprodat_3-1666871236505.png

Alex_at_Exprodat_5-1666871323816.png

Removing multi-language support for your surveys doesn't seem like a reasonable workaround, so we will be submitting a ticket with Esri to try to get this resolved as it appears to be a bug in the Survey123 website rather than an issue with the survey itself.

0 Kudos
Ruth_JiatengXu
Esri Contributor

Hi @NurbekGabdullin @Alex_at_Exprodat ,

Thanks for sharing here! The issue has been fixed on BETA (https://survey123beta.arcgis.com/). If possible please help verify the fix. Fell free to let me know if you have any questions.

Thanks,

Ruth

0 Kudos
NurbekGabdullin
New Contributor

Hi Ruth,

It works in BETA, can you please advise when this is going to be in production?

 

regards, Nurbek

0 Kudos
Ruth_JiatengXu
Esri Contributor

Hi @NurbekGabdullin @Alex_at_Exprodat ,

The fix is bow available on the production environment.

Thanks,

Ruth

0 Kudos