Image Selection in Survey123 App

3185
28
02-03-2017 12:23 PM
DeanSzumylo
New Contributor II

When a survey includes an Image field, there are two options: 1) take a picture, or 2) select an image.   I'm having problems with the second option.  

My assumption would be that when taking the survey, if I select the folder icon, the survey would open the photo gallery on my phone, allowing me to select from the photos/images already stored on my device.   Instead, I'm directed to a blank "No pictures found" screen.  At the bottom of that screen, there's a rudimentary folder selection screen.

The default folder location was not correct. I eventually found where my existing photos are stored, but it took a lot of trial and error.  With the correct folder selected, the images were stored in reverse chronological order (oldest first), so the most recent images would be at the very end of a long list of image files.

Is this the intended behavior?  I can't imagine expecting a survey user to go through this sleuthing process to add an existing photo to a survey.  What am I missing?  Why doesn't the app open the photo gallery?

My phone is a Moto X (2nd generation), Android version 5.1

28 Replies
JamesTedrick
Esri Esteemed Contributor

Hi Dean,

Android, unlike iOS, doesn't have a unified access point for all images; they retained the separate camera folder (DCIM) to essentially make the device look like a standard camera when plugged in or the sdcard is inserted.  I'm a little surprised that you were forwarded to the DCIM folder- Survey123 should be going to the Pictures folder.  This might be a peculiarity of how the settings of the Moto X phone are configured.

SPNIOrganization
Occasional Contributor

Hi,

I'm having the same problem with two different android devices.

I tried browsing to the right folder inside the device with no success.

it seems like the app is not communicating with the photos stored in the device.

I hope the survey123 team works on a friendly solution for this issue because if it will stay like this we will have to find a different app

and I prefer not to do that..

Dikla.

0 Kudos
JasonBone2
New Contributor II

Hello,

Survey123 app is crashing when trying to select a photo stored on the device. I am using Android 7.1.2 and latest version of Survey123 app. I tried reinstalling it and also updated and republished the survey to try to get it to work, but no luck. This functionality was working a few weeks ago, so it might be after I updated to Android 7.1.2. 

Works fine on an ipad with the same survey. Seems like an Android OS issue. Any thoughts?

Thanks,

Jason

0 Kudos
TinaJin1
Esri Regular Contributor

Hi Jason

I have tested on Pixel (Android Version 7.1.2) but didn’t see the crash issue.  May I know what kind of device you have? 

Tina  

0 Kudos
JasonBone2
New Contributor II

I am using a Nexus 5X.

0 Kudos
CamilleBarnett
New Contributor II

I am having a similar issue not being able to attach existing images, but the sleuthing results in EMPTY folders.  I am using a Samsung Galaxy Tab S2, and have tried going through both the SDcard and tablet folders to access images, and can't get any actual image files (or any other file for that matter) from any location to show up for selection.  The only way I can view and select images is if I plug in the tablet to the computer, copy images from those locations, and paste them into the Pictures folder for Survey123.  Oddly enough, when I follow the pathway displayed at the bottom of the screen for that image, the folder that I KNOW is storing it, shows as empty... 

deleted-user-st4HsVxccxgs
New Contributor III

I too am using a Samsung Galaxy Tab S2, and I see the same problem. I have pictures saved in multiple folders on the device, but navigating through Survey123 yields only empty looking folders. This might be a new issue, as I have been using my device for most of the year, and I do not think I had this issue before. Currently running version 2.4.72

0 Kudos
CamilleBarnett
New Contributor II

When you are looking at the blank looking folder, select the "Choose" option in the bottom right hand corner of the screen.  Not very intuitive, but it worked!

0 Kudos
Lake_Worth_BeachAdmin
Regular Contributor

same results here with Samsung galaxy S7

0 Kudos