How to enable users to rank their selections from a multiple choice question?

888
4
Jump to solution
04-05-2022 04:59 AM
PeterKnoop
MVP Regular Contributor

I have a use case where users need to pick one or more options from a list and then rank their selected options.

I thought this might be possible using Survey123Connect, however, while it works in preview in Survey123Connect, the form generates an error when accessed in the Survey123 web app.  

The approach I took was to create two choice lists. The first for the the select_multiple where the user picked their activity, and the second for the rank question:

PeterKnoop_1-1649159332129.png

I then set the choice_filter for the rank question to use the selected answers from the select_multiple question, i.e., selected(${activity_select},activity):

PeterKnoop_0-1649159279552.png

In Connect's preview, this appears to work as intended. The rank question only presents the options that were selected in the previous select_mulitple question, and allows you to drag the selected subset into a preferred order.

PeterKnoop_2-1649159863935.png

PeterKnoop_3-1649159893840.png

 

When I try to use the form for real in the Survey123 web app, the rank question does correctly show only the options selected previously; however, as soon as you drag to re-order the list, an error appears, "Please rank all the choices for this question":

PeterKnoop_4-1649159951044.png

 

Is it possible to combine select_multiple and rank questions this way? Anyone have any thoughts on how to address this error, or is this perhaps a bug?

0 Kudos
1 Solution

Accepted Solutions
Jim-Moore
Esri Regular Contributor

Hi @PeterKnoop 

Thanks for reporting this issue. It appears to be the same as a previously reported bug concerning the behaviour of rank questions with choice filters in the Survey123 web app, BUG-000147050. If you're able to submit a bug report to Esri Support that'd be great; our support team can link your bug report to the existing one and that way we can keep you in the loop when any progress is made on it. 

Best, Jim

View solution in original post

0 Kudos
4 Replies
Jim-Moore
Esri Regular Contributor

Hi @PeterKnoop 

Thanks for reporting this issue. It appears to be the same as a previously reported bug concerning the behaviour of rank questions with choice filters in the Survey123 web app, BUG-000147050. If you're able to submit a bug report to Esri Support that'd be great; our support team can link your bug report to the existing one and that way we can keep you in the loop when any progress is made on it. 

Best, Jim

0 Kudos
PeterKnoop
MVP Regular Contributor

Thanks @Jim-Moore. Our support case is now attached to that bug.

by Anonymous User
Not applicable

Hi! Has this topic found a solution? I just attempted this methodology to my own survey and am experiencing the same bug. Is there a workaround to this issue?

0 Kudos
PeterKnoop
MVP Regular Contributor

Remains a bug in the web app. (Works in the field app.) No workaround that I am aware of currently. Feel free to open a support case with Esri referencing BUG-000147050 to show interest in seeing this fixed.