Hidden Fields in App

433
4
01-24-2023 02:01 PM
jbrower
New Contributor II

Hi everyone, I need a bit of help completing this last portion of my survey. Using Survey123 Connect Version 3.15.175 and Enterprise 11. 

So I'm using a select multiple list to have certain textboxes appear when they select certain answers. The web app appears to do exactly what I want, only show certain boxes when certain answers are selected. But for the app, even when nothing is selected the boxes are still there. 

I'm using the integer type and using selected(${column_viol_type}, "violation1") in the relevant column.

The select multiple is select_multiple violations, and the type has 13 different answers to select from. 

Any help would be greatly appreciated. 

0 Kudos
4 Replies
Richard_Purkis
Esri Contributor

Hi @jbrower 

May you share the xlsx form and identify which rows apply to the issue. I wasn't able to recreate the issue in a simple test

Thanks

0 Kudos
jbrower
New Contributor II

I can share a sample from it. The issue applies the same to the 13 pages I have so I have an example from the redacted xlsx. 

0 Kudos
Richard_Purkis
Esri Contributor

@jbrower 

I can partly recreate the issue. The field isn't there upon launch but it doesn't return to not shown under certain workflows

Is this what you are seeing?

Thanks

0 Kudos
jbrower
New Contributor II

Sort of. When I edit the survey in Survey123 Connect, that empty space underneath has boxes where the boxes would come up if they were checked. Here is a picture example from Survey123 Connect and the Web viewapp view.jpgwebapp view.jpg

0 Kudos