File upload question - not relevant and other issues

60
2
06-20-2019 06:34 AM
Highlighted
Esri Regular Contributor

I successfully added a file type question to my webform but it is not relevant if the question before was answered with no. It seems like the (not) relevant option is not available for file uploads. Is that correct? And if yes, why?!

EDIT: I was able to add the rule in webdesigner but it does not seem to respect it when publishing it from connect. 

I find it furthermore disturbing to have this kind of warning showing up for each upload question: File "false" could not be found (leave unchanged if already submitted and you want to preserve it).

And last but not least: I was first wondering was this asterisk wants to tell me but figured out that is means that all types of files are allowed. "support" does not make sense to me in this context, I would rather use "supported file types". 

How would I limit the file types when using the file type question in Connect?

Reply
0 Kudos
2 Replies
Highlighted
Esri Frequent Contributor

Hi Nicole,

The file upload type question is not supported in the field app or Connect. Only image and audio attachments are supported. Therefore it is not possible to limit the types of files that can be uploaded and use that question type on mobile devices.

As for the issue you are seeing web app, can you explain further, are you trying to use relevant and file type question based on a previous answer? Can you provide screenshot of your web designer and settings? Do you get an error or the option is just not there?

Phil.

Reply
0 Kudos
Highlighted
Esri Regular Contributor

Hi Philip, 

Thanks for looking into this. 

The file upload is not displayed correctly in connect and the field app but I can still use it in my form in Connect and is displayed correctly in the web form. I used a dummy survey created in the web form builder to see the settings for the file type that would be allowed and could limit it to pdf (body::mediatype -> application/pdf). 

When I create a form through the web form builder I can set the relevant limitation but when I publish it from Connect it is not respected. 

I could create the form in the web form builder but I have about 100 questions where it is much easier to copy/paste with excel than doing it with the web form plus a select field with 30 countries.

This comes only when published through connect: File "false" could not be found (leave unchanged if already submitted and you want to preserve it).

It looks like I have to decide between the most comfortable way of designing the form and having the best functionality 

Reply
0 Kudos