cannot read properties of null (reading '0')

901
2
03-31-2022 06:34 PM
SFM_MickieSmith
New Contributor III

After I saved an older survey V3.13 as another survey V3.14, published the survey and launched the survey in the browser, I get the "cannot read properties of null (reading '0') error".  Based on the comments regarding this error,  I cleared my browser cache and removed a blank line in the CVS file.  I still get the error. Some of the special characters in the file consists of  ( ) or / . I did not experience any problems with these special characters in the previous survey versions. When I reviewed the file in the Notepad... it showed some of the information with a # sign but it is not in the CVS file from what I can tell. The survey references three CVS files... I attached one of the files for your review.  I hope this helps.

The survey123 connect version is 3.14. Both surveys are still using the V3.13 template version.

Do you have any suggestions on how I can fix this issue?

2 Replies
ZachBodenner
MVP Regular Contributor

Hi, did you ever find a solution to this? I am running into the same problem and I've done all the same troubleshooting steps. I have worked it down to possibly being my pulldata functions. I have three calculations that pull data from a feature service - when I remove them from the xls then it will not show the  "cannot read properties of null (reading '0')" error.

JaredPilbeam2
MVP Regular Contributor

Have you tried setting the survey to the latest version (i.e. under Settings in S123 online)?  I would read Notes, first.

JaredPilbeam2_1-1708097425514.png

I created a survey from scratch and changed some fields to nothing unordinary. At first, I thought maybe the Excel warning (below) was causing the error in the console. But, then I set my survey to always use the latest version and the console error went away. 

JaredPilbeam2_0-1708097380484.png

 

0 Kudos