Calculations work in SurveyConnect but not online

323
4
04-01-2021 09:57 AM
gyetman
New Contributor II

I created a form that calculates values based on a user input (via an Excel file). It works fine in the SurveyConnect interface, but when I publish it the calculations do not work: the output is displayed as empty and NaN for the two numbers that are calculated. I'm running version 3.11.123 of SurveyConnect. I'm publishing to the web, the form will be part of a Hub site. 

Any hints on how to debug the problem, given that everything works fine in the local app? 

0 Kudos
4 Replies
RobertBorchert
Frequent Contributor III

Did you share the form after you published it?

is the Excel file something you created outside of Survey Connect?

0 Kudos
gyetman
New Contributor II

I shared the form (within the organization) and the excel was edited outside of Survey Connect (created from Survey Connect then edited with Excel). 

0 Kudos
Jelle_Stuurman
Occasional Contributor

I also came across this issue once. if I remember correctly it had - in my case - to do with concatenating two string. In excel the string is concatenated correctly using ‘+’, while online this had to be done using the concat() function. See this warning in the documentation of survey123:

74CA715B-807D-413F-B1AD-81AD48633F6F.jpeg

0 Kudos
gyetman
New Contributor II

I only use the + to add numeric values in the sheet. I wonder if one of them is being interpreted as text when it should be a number, I'll check! 

0 Kudos