Survey123 theme-grid: set borderColor property

1262
4
10-22-2019 03:38 AM
Status: Open
RobBlash
Regular Contributor

Setting theme-grid on the entire survey adds borders to every question which are distracting (in my opinion). If we could set the borderColor property in the body::esri:style column it would be helpful!

4 Comments
DougBrowning

And we can adjust the size of those broders.  

(and name the repeat arrows section?)

NicolasRoger

My current work around is to set the backgroundColor of my groups to:

backgroundColor="#D0D0D0"

This is the same color as the borders, so it looks like there is none.

RobBlash

File this under "too obvious for my brain". If you're ever in NJ I owe you a beer.

RalphPlummer

I would like to upvote this because I would like to have borders on some questions within a theme-grid.  Sometimes adding borders gives a sharper look.  With that being said, read below.

I discovered a workaround by accident and have started using this method in all my surveys.  I thought I would share this in case anyone else would like to use it.  I set my surveys to pages only, being my surveys consist of several pages.  Then I assign an appearance of w2, w3, etc... to groups I want to have more than one column.  No borders are seen anywhere unless I want one.  Then I just set borderColor="black" or whatever.

I would like to add that fields within these groups with more than one column will always be w1.  For example, if you set a group to w2 and want the question to use up the entire w2 width, it will not.  It will remain w1.  So one will need to be creative when working this way.

Here is an example of one of my groups set to w2.  Notice no borders.

RalphPlummer_0-1654696219023.png

This is an example of a group set to w2 with nested groups with borders.

RalphPlummer_1-1654696350773.png

I apologize if this method has been known, I just wanted to provide a workaround that may not have been known.