Embed a Story Map into Another Story Map

396
2
Jump to solution
08-26-2021 09:55 AM
MikeMacRae
Regular Contributor

Hello, I have a tabbed theme Story Map we created from the Classic Story map app. We have created additional story maps in the classic version of the app so that we can create 'sub tabs' within the parent story map so that it looks like this:

MikeMacRae_0-1629995745911.png

 

So, as you click through all the top level tabs, each one will show some second or third tier tabs that were created by embedding additional story maps to create the tiered tab experience. To do this, I simply click on the 'Edit' button in the top right corner which opens up a few options below it:

MikeMacRae_1-1629996121184.png

I click the 'Add' button and I can add a new tab. A dialogue opens where I can add a web page and then I grab the URL of another Story Map that has some of it's own tabs created, paste it in and it will populate the tab with the additional Story map and the new tier of tabs.

MikeMacRae_2-1629996320058.png

 

Here's my issue:

Today, I have decided to configure a new story map using the New ArcGIS Story map app. I've added some content to a 'Collection' and published the new story map. I want to embed this new story map under a new top tier tab in my original classic story map but I am getting the following message:

MikeMacRae_3-1629996481030.png

I have checked and re-checked the URL. I have grabbed it both from the Item page of the new ArcGIS Story Map and the URL from the Address bar after I open the Story Map and I keep getting the same behavior. I have even created some very simple test Story Maps and re-tried adding to the Classic Story map and I keep getting the same behavior. For what it's worth, all my URL's use https as opposed to http (I've read that http can cause some issues) so that doesn't appear to be my problem. I'm out of ideas and options. Can anyone suggest a solution? Thanks

 

Tags (2)
1 Solution

Accepted Solutions
MikeMacRae
Regular Contributor

Hi all. So, working with a co-worker, we solved the issue. For our top level classic story map, we have it shared to our Organization and some Groups, but is not shared publicly.

When adding a new tab into the classic story map, a dialogue appears (see below) that gives some configurable options. I added a tab and used the 'Web Link' option to add the URL of my ArcGIS Story Map to the classic story map. What we discovered is that we had to disable the 'Allow members of other organizations to access this content' option. That allowed the embedded Story Map to display. Hope that helps anyone in the future. 

MikeMacRae_2-1630509257338.png

 

 

 

View solution in original post

2 Replies
OwenGeo
Esri Frequent Contributor

@MikeMacRae -- I'm sorry you are having an issue, but I'm not sure why you are seeing that. I am able to embed stories and collections created with ArcGIS StoryMaps inside classic apps, so unfortunately I'm not able to reproduce the problem.

Can you share the URL of the story here so we can try with the same story you are using? If you're not able to share the link here you can contact Esri Tech Support and they can help you troubleshoot.

Owen Evans
Lead Product Engineer | StoryMaps
MikeMacRae
Regular Contributor

Hi all. So, working with a co-worker, we solved the issue. For our top level classic story map, we have it shared to our Organization and some Groups, but is not shared publicly.

When adding a new tab into the classic story map, a dialogue appears (see below) that gives some configurable options. I added a tab and used the 'Web Link' option to add the URL of my ArcGIS Story Map to the classic story map. What we discovered is that we had to disable the 'Allow members of other organizations to access this content' option. That allowed the embedded Story Map to display. Hope that helps anyone in the future. 

MikeMacRae_2-1630509257338.png

 

 

 

View solution in original post