Select to view content in your preferred language

Can not publish storymap

4564
22
Jump to solution
12-01-2021 10:57 PM
JosZwambach1
New Contributor III

I get an error when publish a storymap. It says “Sorry there was a problem publishing your story” “Because of your account privileges, some sharing settings aren’t available. Contact your ArcGIS administrator for more information.”. Yesterday (1 dec) it works fine. I have also tested it with a simple cascade storymap and add a map. In the webmap one layer is added. What is wrong?

22 Replies
JosZwambach1
New Contributor III

Yes this is a workaround, but we don’t want to use the storymap outside our organization.

0 Kudos
JacobBenner1
New Contributor

I am testing with a story that I could publish to Organization and Everyone with text only in the story. Then I added a map that included premium ESRI content, that was shared to Organization level. Attempting to publish that story failed with the same error. Here's the published version link (without map)

0 Kudos
OwenGeo
Esri Notable Contributor

@JacobBenner1 -- Stories that have maps with premium or subscription content will also fail to publish at this time. We're working on a solution for this as well.

I haven't had a chance to test this yet, but I believe a workaround for using premium content would be to follow the instructions in the "Authorize subscriber layers" section of this article: Use ArcGIS Living Atlas subscriber content in public maps and apps (esri.com). I think this will circumvent the need for the story builder to authorize the content and possibly allow you to publish.

Owen Evans
Lead Product Engineer | StoryMaps
0 Kudos
JacobBenner1
New Contributor

OK, Thanks. That's beyond my students' capabilities at this time, so I will wait for another resolution. I am sure they are experiencing the premium/subscriber content issue because many of them used Living Atlas layers in their maps.

0 Kudos
OwenGeo
Esri Notable Contributor

@JosZwambach1 -- Thanks for sharing this information.

Please note that while the example gave was to share with Everyone if you are publishing your story publicly, the workaround works for sharing to the organization as well.

I believe a workaround is to make sure all maps and layers in the story are already shared to the level to which you are publishing the story

Owen Evans
Lead Product Engineer | StoryMaps
0 Kudos
JacobBenner1
New Contributor

OK, Checked the map that I used in the story. It had some premium layers turned off, which I removed. I used only one layer with no restrictions. Shared the map to everyone, then shared the story with everyone, and it worked. Maybe it's something with the ESRI premium layers?

0 Kudos
OwenGeo
Esri Notable Contributor

UPDATE: We are testing a fix in our dev environment now. We plan to deploy the fix later today.

I'll post another update here when there's more information to share.

Owen Evans
Lead Product Engineer | StoryMaps
RichieHolder
New Contributor

Hey Owen,

Could you give an estimate on when the fixes would be implemented? Would it be fixed by 2pm central time today?

0 Kudos
OwenGeo
Esri Notable Contributor

@RichieHolder -- There's a good possibility it will be deployed by 2pm CT / 3pm ET, but I can't confirm that just yet since we still are working on testing. 

Owen Evans
Lead Product Engineer | StoryMaps
OwenGeo
Esri Notable Contributor

@RichieHolder -- Unfortunately, we can't provide the fix any earlier than 5:30pm ET today. That is the first window we could get to safely deploy our software patch.

Owen Evans
Lead Product Engineer | StoryMaps
0 Kudos