Settings to minimize lag in position fix

368
3
12-06-2022 05:08 PM
GeoFinn
New Contributor II

We have created a quickcapture project for doing a windshield survey of ditch locations. Our initial testing with the default GPS location from an IPad didnt provide the desired accuracy. So....we tested with a higher accuracy GPS receiver (bluetooth Arrow 100). This resulted in better accuracy but introduced a lag issue we didn't have when using the standard GPS location from the Ipad. I'm guessing it just takes longer for the higher accuracy GPS to get a fixed location. Our travel speed in the vehicle is about 30MPH. I realize this is a difficult question to answer with so many variables at play but was curious if anyone had encountered this issue and found a suitable solution/platform/GPS Receiver. My next test is to try hard wire vs bluetooth on a laptop to see if that resolves the lag issue. 

Tags (3)
0 Kudos
3 Replies
JohnathanHasthorpe
Esri Regular Contributor

We have tested the Arrow 100 and had good success with it at speed. Could you share more information on the lag you are seeing? Is it that you see a lag in point in the quickcapture map, or is it that the captured points are not in the correct place when viewed in ArcGIS?

The other thing to note is that it should be possible to increase the frequency of updates for the Arrow to say 20hz, this would mean you are getting 20 updates per second.

0 Kudos
GeoFinn
New Contributor II

The position varied from actual location anywhere from 25 to 60 feet. We will proceed with testing the Arrow unit at 20hz. Thanks for the suggestion. 

0 Kudos
JohnathanHasthorpe
Esri Regular Contributor

30mph = approximately 44 feet per second. 

As GPS recivers typically update locations at 1hz (one update a scond), then it could be the issue that you are seeing.

This would be the same for the internal reciever on your phone.

0 Kudos