Map View/ Side by Side Mode Issues

421
10
Jump to solution
07-29-2020 07:01 AM
ClintBoaz2
New Contributor II

I am having a couple problems with quick capture.  First, after downloading a project containing a tile map package (for offline map use) onto a Samsung tablet the map feature is a static grey image with no map.  The same project was able to be downloaded successfully with working maps to apple tablets and an android phone.  Any ideas on this?  Have other run into similar compatibility issues?

Second, I am having no luck trying to initiate the map/ button side by side mode on a tablet.  I have the box checked in the designer and have tried several different device templates.  I am using a couple of iPads that I do not believe are Pro (which is what is listed in the template options).  Is this side by side feature only available to certain devices (like the devices listed in the template options)?  Any ideas on why this side by side feature is not initiating when changing to landscape view on my tablets?

Any advice would be greatly appreciated

- Clint 

#quick_capture‌, #offline map areas‌, #side by side view

0 Kudos
1 Solution

Accepted Solutions
JohnathanHasthorpe
Esri Regular Contributor

Update on this: 1.7 (due for release next week) has a fix for the runtime issue mentioned above. You should be able to use this build on your Tab 4 device.

View solution in original post

0 Kudos
10 Replies
JohnathanHasthorpe
Esri Regular Contributor

Hi Clint,

Can you share more details on the Samsung device that you are having issues with -  device model and Android version? Can you also confirm that you are getting a valid location on the device? It may well be the map is opening at an extent outside of the limits of your TPK.

Secondly, you need to open the project when you are in tablet mode. You can't rotate the app when in the project and have it updated. The workflow is to rotate the tablet to landscape, go to my workspace page, and then open the project. If the project has been enabled to for spilt screen (in map settings in the designer) the project should open side by side.

Thanks

John

0 Kudos
ClintBoaz2
New Contributor II

Hey Jon,

Thanks for the reply.  The side by side mode is working just as you said.  The tablet is a Samsung Tab 4 running android 5.0.2.  I am a relative beginner so I may be misinterpreting but if you mean a current location marker I am not.  When I open the map it is all grey with no marker and no gridding.  

If I may  add another question...  Is there a good way to keep the pictures attached to features when converting to shape files?

Thanks,

-  Clint  

0 Kudos
JohnathanHasthorpe
Esri Regular Contributor

Hi - Can you capture a point in the project page? If so, you are getting a valid location. It is just that the map is not displaying.

If that is the case could you share the project with the user QCCreator (you will need to create a group and share the project with it. Then invite the QCCreator user to the group) this will allow us to download and test the project.

Thanks very much

John

0 Kudos
ClintBoaz2
New Contributor II

Hey John,

Just shared it with QCCreator, thanks for all your help.

-  Clint

0 Kudos
ClintBoaz2
New Contributor II

When I collected a point with the Samsung device the point never displays on the device but it uploads with the correct location when data is sent to the hosted feature layer in AGOL.  Seems strange as I have tried multiple different tile map packages that have all worked on other apple and non apple products.

JohnathanHasthorpe
Esri Regular Contributor

Hi Clint,

The Samsung Tab 4 is an ARMv7 32-bit processor. There is an ArcGIS Runtime 100.8 bug that prevents maps loading on ARMv7 devices on Android 5. This affects other Esri apps including Survey123 and Collector.

I'll update this post with progress on this. If anyone else needs support for such devices, please comment on this post.

Thanks

John

ClintBoaz2
New Contributor II

Hey John,

Yes, that clears things up.  Thanks for the response.

-  Clint

0 Kudos
JohnathanHasthorpe
Esri Regular Contributor

Update on this: 1.7 (due for release next week) has a fix for the runtime issue mentioned above. You should be able to use this build on your Tab 4 device.

View solution in original post

0 Kudos
JesseKalwij1
New Contributor II

Dear John,

Not sure if you reply to solved issues.....

I am running QuickCapture 1.9.130 on an Galaxy Tab Active2. The 'display on tablet option' is enabled. I am using your workflow by first putting the tablet in landscape and then open the project, but I still cannot get the side-by-side option to work.  Any advice would be appreciated.

Quickly switching between the main QuickCapture screen and the map is tedious, because  the 'map' button on the main QuickCapture screen is on the top right, whereas the 'close' button of the map is on the top left. Surely this can be changed easily? 

Thanks in advance for your advice,
Jesse

0 Kudos