Why getting error "Can't ConstructUnion on a point" with Create Replica tool?

548
3
06-13-2023 04:17 PM
AllenDailey1
Occasional Contributor III

Hello,

I am using the Create Replica tool in ArcGIS Pro, version 3.0.3, and I got error 002829 "Can't ConstructUnion on a point."  Why??  this does not make any sense to me, because I am creating a replica, not doing anything with a union.  Any ideas?

I am trying to create a replica from one Feature Dataset to another Feature Dataset in the same database.  That might seem weird; it's for testing.  The prod environment has replicas from one database to another, but the dev environment only has one database, so I'm trying to approximate prod in dev the best I can.

The replica consists of only one feature class, a point feature class.

Parameters:  one way, parent to child, simple model

I'm using what I think is the right database service account to run Pro to create the replica.

Thank you to anyone who has ideas!

0 Kudos
3 Replies
Robert_LeClair
Esri Notable Contributor

@AllenDailey1 - there is a not terribly helpful technical article here that has a solution "Do not use point features as input for this operation."  What geometry type is your point feature class?  Point, PointZ, Multipoint?  I would copy/paste the feature class outside of the feature dataset and try to create the replica again.  What is the result?

0 Kudos
AllenDailey1
Occasional Contributor III

Thank you, Robert!

Another person tried creating the replica, and it worked.  It's a mystery!  I'm all set now.

0 Kudos
Robert_LeClair
Esri Notable Contributor

Excellent!  I guess we can attribute it to a glitch in the matrix then...

0 Kudos