Uploading an ArcGIS Pro Template Issues

319
1
01-29-2020 04:00 PM
KieranSroba
New Contributor II

Hello GeoNet Community! 

I am struggling to get a ArcGIS Pro project template to upload to Online and function properly mainly due to (I believe) pre-loaded toolboxes. We have previously uploaded this template with the same default toolbox and didn't seem to have the same issues so I am a little baffled as to how to proceed. For information the default toolbox is on a shared network drive the team can access, template set up is attached in "Setup1.jpg". The goal is to not download the toolbox every time we create a new project but for the template to reference the toolbox on the shared drive. What I have tried so far: 

Upload template to Online account 1: the upload finished and the template is view-able online, however when the template is downloaded to create a new project the default toolbox is overwritten with an empty toolbox. 

Upload template to Online account 2:  With the "Include toolboxes" checked I receive an error of "Failed to package" and the "SharingJobLog.log" attached. Thinking this may be an issue with a specific code set I have tried removing all toolsets from the toolbox and re-uploading but received the same error. 

Save template to file 1: receive the same error as "Upload template to Online account 2"

Any help would be greatly appreciated, as I mentioned I am not sure where to go from here. 

1 Reply
LeandraGordon
Occasional Contributor II

Hi Keiran - I'm having trouble with the Create Project Template as well - but I'm just trying to create a file for our users to download to their desktop. It just doesn't seem to work with the 'Include Toolboxes' option. 

I'm on ArcGIS Pro 2.4 - what version are you using?


The only problem I can see is the location of the toolbox (C:\Users\kpsroba\Desktop\Pro script temp\GHD_MiscellaneousTools_Pro.tbx)
1) Maybe try having toolbox located somewhere not linked to a username (C:\Data\)
2) Also I wouldn't use a path name with spaces e.g "Pro script temp", Theoretically it should probably work but after 25+ years of programming I still don't trust anything (Windows, Office, SQL etc) to actually handle anything with spaces in the long run, I still stick to good old underscores.

But it might be a bug. Do you have ESRI Support? If not I might go through our support and submit it to ESRI Australia to then submit to ESRI USA.

0 Kudos