Summarize Within tool failing to calculate value for all polygons

260
2
01-29-2021 10:16 AM
Labels (1)
HeatherChamberlain
New Contributor

I'm using Summarize Within with (1) a set of polygons providing spatial units, and (2) a dataset of building footprint polygons. The building footprints each have a pre-calculated area as an attribute. All building footprints are within a spatial unit polygon (i.e.none span spatial unit polygons). Both polygon datasets are feature classes within the same geodatabase. 

I am using Summarize Within to summarize the building footprint area for each spatial unit. I am doing this for multiple areas, and the datasets can be quite large. This works fine for smaller datasets and some of the time for larger datasets, for example running for 15,000 spatial units in one area. However at other times the Summarize Within calculation seems to fail after it's got through so many spatial units, but no error message is produced. For example with one dataset, the output from Summarize Within was good for spatial units with OBJECTID values up to approximately 18,500 and all OBJECTID values after that had a 0 value. Re-running the same operation with the same dataset also didn't produce an identical result - it seems the calculation stopped at a different OBJECTID value. Has anyone encountered similar, or can shed any light on this? Or successfully used Summarize Within with really large datasets?

I'm running this from a notebook in ArcGIS Pro 2.5.1. 

0 Kudos
2 Replies
Amadeus111
Occasional Contributor II

You might have a problem with the geodatabase or geometries. Try to convert them into shapefile and repeat the process if helps. 

0 Kudos
HeatherChamberlain
New Contributor

Thanks for the suggestion. Running repair geometry before using Summarize Within does seem to help in some instances but in others I'm still having the same issue unfortunately.

0 Kudos