Unable to save new polygons in 2.3

594
12
01-25-2019 02:06 PM
LiamTurley
New Contributor III

Updated to 2.3 unable to save new polygons while digitizing. No error code just message informing me it does not work. 

0 Kudos
12 Replies
Scott_Harris
Esri Regular Contributor

Hi Liam,

  • Where is the data sourced from (ex. File Geodatabase? Enterprise Geodatabase?, etc.)
  • On the editing tab, in the Manage Edits group, there is a Status tool that maybe can give some clues: Get started editing—ArcGIS Pro | ArcGIS Desktop 
  • Is the problem specific to a certain ArcGIS Pro Project?

Thank you,

Scott

0 Kudos
LiamTurley
New Contributor III

Good afternoon Scott, 

Thank you for replying to my post. The data is being sourced from a geodatabase and it is not project specific. Under the Status tool, it indicates features are editable. I have also noticed that the same applies to adding lines and points, as well as it is not an issue when adding polygons to an existing shapefile, it saves just fine. Feature classes seem to be the issue. I have not done anything different then I would while creating and editing with version 2.2. 

Thank you, 

Liam 

0 Kudos
Scott_Harris
Esri Regular Contributor

Thanks for the reply, Liam. That is definitely odd behavior. A few more questions:

  • Is the issue specific to a certain File Geodatabase (FGDB) or does it occur in all FGDBs?
  • If so, when and how was the FGDB created?
  • Where it it sourced on disk (local drive or network location)?
  • Do you have ArcMap installed on your machine? (Perhaps you can test with it too)
  • Do you have another machine you can try it on?

If we can't get to the bottom of it here in a decent time frame, please call Esri Technical Support at 888-377-4575.

-Scott

0 Kudos
LiamTurley
New Contributor III

Hi Scott, 

I tried editing a feature from another geodatabase and it seems to work just fine. I don't know why but it seems that my working geodatabase is corrupt, it was fine until the update. I made a new geodatabase and it seems to work fine. 

Thank you for your help. 

Liam

0 Kudos
Scott_Harris
Esri Regular Contributor

Hi Liam,

I'm glad you have a way forward; however, I think it would be worthwhile for us to look further into the issue - if you are willing, of course. It's probably best if we did this by opening a case with Esri Technical Support. The phone number is 888-377-4575. Please let me know once you have an open case, or if you hit any roadblocks.

Thank you,

Scott

JoeBorgione
MVP Esteemed Contributor

https://community.esri.com/thread/227796-cannot-edit-since-upgrade-to-23   Should cure it....

That should just about do it....
LiamTurley
New Contributor III

I saw that post and thought the same thing and checked to see if it was selected (it was not) it just does not want to save edits within the feature class (making new attributes).  

0 Kudos
JoeBorgione
MVP Esteemed Contributor

Just for fun, see if you can make the same edits to the offending gdb with ArcMap.

That should just about do it....
ScottSweet2
New Contributor III

I also have this problem.  I cannot edit any feature classes.  I even created a new one, then tried to edit and it doesn't stick.  Whether you try to move a feature, edit vertices, etc. It just reverts back to the original shape/location after clicking on "finish".  Seems like a major bug.  I didn't have this problem at all before installing 2.3

0 Kudos