Transfer Attributes now available but not working

502
4
03-02-2021 11:50 PM
PSAQATAR
New Contributor II

Transfer Attribute Tool is now available but it seems not working or I maybe missing something.

It seems pretty straightforward but it simply not transferring although message "Attribute transfer completed"

PSAQATAR_0-1614757505217.png

I have tried Saving Edits ( included when u save d project ), re-open the Table, re-open the project but nothing happens.

Went back to the good old ArcMap, done , straight away the open table view is updated .

 

 

4 Replies
JosphatM
New Contributor II

The tool has been implemented different than in ArcMap.

Once you have applied your Field Mapping Settings from the Editor Settings burger button, follow the informational notifications on the tool to select the source and target features on the map - https://pro.arcgis.com/en/pro-app/latest/help/editing/transfer-attributes-between-features.htm

JosphatM_0-1614875292342.png

Please note that to transfer geometry, you need to match the Shape fields of the source and target layers in Field Mapping - https://community.esri.com/t5/arcgis-pro-questions/geometry-transfer-in-arcgis-pro/m-p/1016232#M3593...

JosphatM_1-1614875503150.png 

In ArcMap, this was implemented by checking the 'Transfer Geometry' box.

Esri has also added a Help button that links to online help resources on all Editing tools.

JosphatM_4-1614876117237.png

I hope this helps.

0 Kudos
MKresky
New Contributor

I am experiencing this same issue. I have all attributes linked correctly and follow the prompts as directed. It shows attribute transfer completed and still in my table no attributes have been transferred. 

BrookeAumann
New Contributor II

Having this same problem- and in Arcmap (if it was points overlapping) it respected the order of target and source. I got my stuff to work by turning off my target> clicking the transfer tool and the source point> turning my target point back on and clicking. It doesn't look like the tool recognizes the order if the features are overlapping. Maybe this is isolated to points- but I wonder why this is happening and what I can do about it? 

MattGoodman1
New Contributor III

@BrookeAumann hit the head on the nail. Can we get this fixed?