Train Deep learning model error

3604
10
Jump to solution
08-25-2020 06:43 PM
Honey_JaneEstarija1
New Contributor

ERROR 032659 updateParameters Execution Error: Traceback (most recent call last):
File "c:\program files\arcgis\pro\Resources\ArcToolbox\toolboxes\Image Analyst Tools.tbx#TrainDeepLearningModel_ia.UpdateParameters.py", line 1, in <module>
File "c:\program files\arcgis\pro\Resources\ArcToolbox\toolboxes\Image Analyst Tools.tbx#TrainDeepLearningModel_ia.UpdateParameters.py", line 66, in updateParameters
File "C:\Program Files\ArcGIS\Pro\bin\Python\envs\arcgispro-py3\Lib\site-packages\arcgis\learn\models\_retinanet.py", line 137, in _supported_backbones
return [*_resnet_family]
NameError: name '_resnet_family' is not defined

I'm getting this error. not so sure why. this is my first time using this feature of ArcGIS pro. 

1 Solution

Accepted Solutions
DanPatterson
MVP Esteemed Contributor

Install deep learning frameworks for ArcGIS—ArcGIS Pro | Documentation 

Base info and links to Pro 2.5

Then there is the link for 2.6 for the required installation

https://www.esri.com/content/dam/esrisites/en-us/media/pdf/install-deep-learning-frameworks.pdf 

Everything OK with the installation?


... sort of retired...

View solution in original post

0 Kudos
10 Replies
DanPatterson
MVP Esteemed Contributor

Install deep learning frameworks for ArcGIS—ArcGIS Pro | Documentation 

Base info and links to Pro 2.5

Then there is the link for 2.6 for the required installation

https://www.esri.com/content/dam/esrisites/en-us/media/pdf/install-deep-learning-frameworks.pdf 

Everything OK with the installation?


... sort of retired...
0 Kudos
WillBraganza
Esri Contributor

Did you use the "Export Training Data for Deep Learning" tool to create the input for that tool?  If so,  do you recall what you set the meta data format as?  I know there can be issues with this error code when using KITTI Labels

GiuseppeDiCaprio
New Contributor

Good Evening,

I've the same Issue, did you get the solution ? If so, could you tell how to resolve ?.

Thanks a lot,

Giuseppe

VinuChandran
New Contributor

Updating ArcPro to 2.6.3 version fixed this for me.

0 Kudos
7177
by
New Contributor II

Hello, 

 

I got the same issue on ArcGIS Pro 2.7 and frustratingly haven't found neither an explanation nor a solution for the error. 

 

ERROR 032659 updateParameters Error: Traceback (most recent call last):
File "c:\program files\arcgis\pro\Resources\ArcToolbox\toolboxes\Image Analyst Tools.tbx\TrainDeepLearningModel.tool\tool.script.validate.py", line 261, in <module>
File "c:\program files\arcgis\pro\Resources\ArcToolbox\toolboxes\Image Analyst Tools.tbx\TrainDeepLearningModel.tool\tool.script.validate.py", line 117, in updateParameters
backbone_list = training_model._supported_backbones()
File "C:\Users\p.funovits\AppData\Local\ESRI\conda\envs\arcgispro-py3-clone3\lib\site-packages\arcgis\learn\models\_classifier.py", line 179, in _supported_backbones
return [*_resnet_family, models.mobilenet_v2.__name__]
NameError: name '_resnet_family' is not defined

 

I'm getting peculiar errors with more than one of the available models btw. Mask RCNN is _the_ only one I get results from at all, the rest doesn't really work for me. 

 

Any input welcome!

 

And yes, I re-cloned the standard environment and re-installed the deep learning packages and so forth. No luck.

0 Kudos
ZorkoSostaric1
Esri Contributor

Just before Christmas I got new laptop and installed ArcGIS Pro 2.7. For a support call I had to test deep learning and I did the following only:

Install Deep Learning Framework from
https://github.com/Esri/deep-learning-frameworks/releases/tag/pro-2.7
You DON'T NEED to clone Python environment or manually add any packages
run this lesson https://learn.arcgis.com/en/projects/use-deep-learning-to-assess-palm-tree-health/
and it all worked just fine. 

On old laptop with 2.6 I had the same error and eventually I fixed it by cloning Python environment and installing Deep Learning Libraries but it was a messy process and I am not sure what part actuall fixed it.

At least with 2.7 should be lot easier.

7177
by
New Contributor II

Reinstalling 2.7 and repairing the framework installation solved the problems I encountered...

by Anonymous User
Not applicable

This is absolutely lame error and I am getting it again and again, tried to update installation, DL libraries etc. nothing works. I am applied Deep Learning Researcher and can see this DL training method has so many fragile places it breaks on. I can see images in ImageChip folder(where I have created training data) and I did use Pascal VOC format. But when I select the ImageChip folder in Train Deep Learning Model tool's Input Training Data field, it gives this error. 

 

This training data was created by ArcGIS Pro itself and being used by ArcGIS pro itself again. How can it give error? is the product not integrated enough? little dis-appointed in this simple use-case.

7177
by
New Contributor II

Hi, what ArcGIS PRO Version did you use, if you don't mind me asking?  

0 Kudos