Task Error: "Cannot run command assigned to the step. It is not enabled." Trying to make layer from selected features

525
2
12-13-2022 10:01 AM
Labels (1)
AndrewWallick
Occasional Contributor

I have a task with two select layer by location steps and one select layer by attribute step, then I would like to make a layer from the selected features. But I keep getting the error "Error : Cannot run command assigned to the step. It is not enabled."

I've tried adjusting the Contents settings to only show the layer I am selecting from, but that hasn't made a difference. This comment in a similar post is what I've been trying to replicate, but I'm not sure why it isn't working.

AndrewWallick_1-1670954373314.png

 

 

 

2 Replies
PhilLarkin1
Occasional Contributor III

I get this error when the tool or command I am trying to run relies on a layer or other resource in the project that is variable; for example, a layer or version name is different each time the project is opened. 

Did you find a solution to your problem?

0 Kudos
csos
by
New Contributor

I'm also getting that same error. (Found 1 error(s).
Error : Cannot run command assigned to the step. It is not enabled.) Ive been troubleshooting for quite some time. I read in an older post that it might be a bug? Anyone have a solution?  Ive tried disabling all options on the layers that I dont want to copy from.  (ArcGIS Pro Desktop 3.0)

Workflow

Select a road

Copy that selected road

Paste Special into another feature class named traffic calming

Merge the road to the selected feature in traffic calming.

Running this workflow manually works fine but Tasks seems to not like it. 

 

Thanks in advance

 

csos_0-1678920100133.png