Save Edits Failed in ArcGIS Pro

4392
14
03-20-2018 12:14 PM
GrantHelete1
New Contributor

I have been working on a project in ArcGIS Pro 2.1.2 and as of this morning have been unable to save my edits that I have made to data in a map (in map mode, not layout mode). I am able to make the edits, but when I go to save them I get the following error window:

Save edits failed screen


If I try to make additional edits and save them after I receive this notification, the "Save Edits" button becomes grayed out like so:


Unable to use "Save Edits" button

I have tried to edit several different layers (ensuring that I am only editing one layer at a time), and each time I have received this error. I have also shut down and restarted the program several times and this problem is still occurring. I have even removed the map and added it back in to the project, and the error still occurs each time I try to make edits. This leads me to believe that it is an issue with the project itself, but I am not sure what kind of issue that would be. I have looked around to see if anyone else has had the problem, but have been unable to find any such forum post/Stack Exchange/etc.

The project uses an imported .mxd from ArcGIS 10.3 as the basis for its layout (which was imported when the project was created), and the map I am editing was created from one of the map frames in the layout mode. This is my first project for which I have used ArcGIS Pro (I have previously only used ArcGIS 10.3/10.4), so I apologize if any of my Arc GIS Pro terminology is inaccurate/confusing.

 Any help that anyone could provide would be very much appreciated. I am also more than happy to provide any and all additional information that would be helpful.

Thanks!

14 Replies
DanPatterson_Retired
MVP Esteemed Contributor

Start a clean project an add one data layer to it.  Can you edit and save it?  You might want to make a copy of the layer to a new file geodatabase first.

0 Kudos
JeromeHaaland
New Contributor III

Problem is still happening in 2.6

Scott_Harris
Esri Regular Contributor

Hi Jerome,

This could be a data/project specific problem, and would be difficult to troubleshoot on this forum. Please contact Esri Technical Support as they can help narrow down what could be causing the issue.

Thanks,

Scott

RuthAslanis
New Contributor

I am having this problem also.  Could this be a bug? Are there limits to how many layers are in default.fgdb?  I did save the project after dicarding the edits and reopenned in ArcGIS Pro.  It saved once for a few edits and then message reappeared on second batch.  Both in small number of edits.

StephanieKambic
New Contributor II

I wanted to bump this thread because I am having this problem (in August 2021) and it's been happening for a few months. Has anyone found any success in troubleshooting the error? 

anna_garrett
Occasional Contributor III

I just had this exact same issue and it turned out I'd forgotten I was editing the same line feature class in ArcMap (long story, I have to edit my annotation in ArcMap for the time being since it's not compatible with Pro). 

I think when there's no explanation or error code it's probably something like that. Wish there was an error code or a more descriptive message though.

SRanseen
New Contributor III

have been having same issue since last arcpro update.  I have turned on to where it saves edits every few minutes but very frustrating to have to go back and redo work again and again.

Edit (Jan 2022): since posting this issue has mostly gone away since arcpro had recent updates.  I did end up having to fully remake my master layers I was editing because they would no longer edit at any level.  After the update and the remake this issue has stopped happening.  Don't know why and don't know why my layers corrupted.

I had one of my users also having the same issue in arcmap 10.7 and after video card and computer updates issue stopped occurring for them.

IBWadmin
New Contributor III

I began getting this fail today in AGP 2.9.0, working on a layer from AGOL.
I tried loading the layer in a new project, new map, with the same issue arising.
Do users have any other practical suggestions?

IBWadmin_0-1641422116515.png

 

 

mmm3
by
New Contributor III

Same here, 2.9.1

Considering copying the layer then overwriting it, but I have a lot riding on this data, so I'm reluctant to go that option