"Tool has failed to open" error in ArcGIS Pro

09-02-2018 03:41 PM
New Contributor III

I am attempting to open the Profile tool in 2.2.1, but the tool does not open and I get the following error:

I have tried repairing the installation, but there was no change.

Anyone know what is going on? Difficult to evaluate software that doesn't work.

0 Kudos
22 Replies
Esri Contributor

Hi Carolyn.

Tools in the Ready To Use toolbox are ArcGIS Online geoprocessing services that use ArcGIS Online’s hosted data and analysis capabilities.

Please check if you are logged in to ArcGIS Online (will use your AGOL credits) in ArcGIS Pro.

For more information for this specific tool, have a look at the Profile tool's help documentation.

I hope this helps.


0 Kudos
New Contributor

I'm having the same issue in ArcGIS 2.8 loading the "XY Table to Point" tool or the "Display XY Data" tool. I tried renaming my Esri folders in AppData but nothing has worked. 

0 Kudos
Occasional Contributor

Have the exact same problem as DarcyGray1. XY Table to Point tool or Display XY Data tool failes to load... I'm on 3.0.3 version..

@DarcyGray1  Did you find a solution?

0 Kudos