Select to view content in your preferred language

Project Package to Enterprise Database unsaved password

1511
5
01-02-2020 01:48 PM
JimmyBowden
Occasional Contributor II

Using ArcGIS Pro 2.4.3.  I'm attempting to create a project package that is connected to an enterprise database (Oracle or postgres).  The aprx was created with no user/password saved, so that credentials have to be entered each time the aprx is opened.  When I attempt to publish this project I am prompted for a Database connection username and password as expected.  When I enter a username and password and hit Ok, a new Database dialog comes up (this continues every time I hit ok.  If I cancel a message saying "Failed to connect to the specified server." Then the Share Project Package fails.

I checked the logs on our postgres server and it doesn't seem to even try to connect.  On a co workers machine the Database connection dialog doesn't come up but the process fails.

Error message: ERROR 001707: Data cannot be opened: SDE(SERVER=development;INSTANCE=sde:oracle11g:development;DBCLIENT=oracle;DB_CONNECTION_PROPERTIES=development;PROJECT_INSTANCE=sde;VERSION=SDE.DEFAULT;AUTHENTICATION_MODE=DBMS) 

Should we be able to create a project package without storing a username and password?  arcgispro 2.4 project package

5 Replies
JimmyBowden
Occasional Contributor II

Created a support case for this and it was a known issue.  Expected to be fixed in 2.5.

0 Kudos
AndrewHargreaves1
New Contributor III

Hi

I'm using Pro 2.5 but experiencing something similar. Here's my setup:

  • Pro Doc accessing Feature Services through a AGO group
  • Feature Services are simply items within AGO, referring to ArcGIS Server services
  • These services have a password, which is embedded when registering the URL in AGO

It all works in Pro, but when attempting the package the Project I get:

ERROR 001707: Data cannot be opened:

I assume this is perhaps due to what you mention, that the password to access to services isn't being passed to Pro during the packaging process? JIMMY BOWDEN‌ do you have the case number in order to track progress?

Thanks

0 Kudos
AndrewHargreaves1
New Contributor III

Now at 2.5.2 and still no fix.

DevinWelty1
New Contributor II

Does anyone have a solution to this? I really need to package up the maps and data for this project to share. The data is on AGOL....

Thanks

0 Kudos
GlenColgate1
Occasional Contributor

Now at 2.9.2 and this still appears to be an issue.

Only work around that I have been able to come up with is:

  1. Setup map with data connection where user/password is saved.
  2. Run Package Project to success
  3. Deselect the Save User/Password in the database connection
  4. Run Package Project again

If the Package Project is run first with the database connection where user/password is NOT saved no subsequent packages will be successful. Only if the first attempt at Project Package is run with saved credentials will the second run without saved credentials work. I have only tried this with a sde connection file saved in the project folders.

Seems to work for me. Hope this helps others.

0 Kudos