Pro doesn't update folders or files "in real time" within GDB when modified outside of Pro

6196
22
01-30-2017 03:10 PM
TylerSchwartz2
Occasional Contributor II

I am running ArcMap for Desktop and ArcGIS Pro both at the same time.  As I update or change data in a geodatabase while using ArcMap, these data do not properly update in Pro (even if they aren't currently part of a map in Pro). Its as if Pro sees the files and folders as frozen in time (when Pro was launched), and doesn't update them in real time.

 

Example:

I modify the attributes/fields of a feature class in ArcMap (even if it is not loaded in the Pro map, which if it was I would probably get a schema lock). If I then add that data to Pro it adds the old dataset as it was when Pro was originally launched - without the updated attributes I edited in ArcMap! There is no apparent way to refresh the folder or data in Pro, so it will update correctly. Its as if Pro isnt getting live updates to folders and files and doesn't recognize when those files are moved and modified outside of Pro. 

Another example:

Iif I add or delete feature classes within a GDB outside of ArcGIS Pro, and try to add them - Pro still sees the old FC's even if they are gone.  Trying to add them gives error "Failed to add data, unsupported type" obviously, the file isn't there anymore. 


The only work around is to close out of Pro and reopen (pretty big inconvenience if you are working with both software simultaneously - ie: Business Analyst in ArcMap and symbology/cartographic work in Pro)

Bug or working as intended?

PS: I should mention that you can, however, see new feature classes that were created. it's the deleted FC's that are still showing within the GDB, and current ones that were modified are not having those modifications update correctly.

22 Replies
JoshuaBixby
MVP Esteemed Contributor

I ran into an issue the other week while helping a fellow GeoNet user where Pro would not see changes to the schema of a CSV file, even after closing Pro and re-launching it.  I had to make a copy of the file and change the name for the schema change to show up correctly.

Are you working with file geodatabases?  I am starting to wonder whether Pro does some aggressive caching of file system files, FGDB included, and whatever triggers that should cause re-caching don't work well.

0 Kudos
TylerSchwartz2
Occasional Contributor II

I am also seeing issues with the folder structure being wrong when adding data in Pro.  One of my project folders (which is located on a network drive) is actually showing up on my C:/ directory.  I am attaching screenshots to show.  Also to note, is that that project folder which is mysteriously showing up on C:/ doesn't point correctly to the network location either.

You can see in the screenshots that the folder "GIS" is a project folder that is supposed to point to a location on our network (L:), but apparently Pro thinks GIS = "C:/My Output Data"

Screenshot 1 (Capture.jpg) = C drive according to Pro (notice the folder "GIS" is taking the place of "My Output Data")

Screenshot 2 (Capture2.jpg) = Actual C drive (notice no "GIS" folder, presence of "My Output Data")

Screenshot 3 (Capture3.jpg) = Project folders, note GIS folder in particular is showing the contents of "My Output Data" but its actually supposed to have completely different contents

Screenshot 4 (Capture4.jpg) = Actual contents of "GIS" folder located on the network drive

I think this particular issue (maybe unrelated to the original post?) is related to the bugs with Project Templates. I originally set the "GIS" Project folder up in my Project Template to point to a network location. When I open a new project with this template, it points to "My Output Data", and takes its place in my C: drive (in the Pro interface)...  

Not sure if this issue is related to the original post - might be two separate issues...

Can anyone at ESRI reading this pass this along to support and get these two (related or unrelated) issues addressed?  I honestly do not have 2-3 hours to submit a bug (submit, go back over it with support, have them replicate it, and finally get it reported).  Ive gone through that process too many times already just with Pro, I dont have time for it anymore.  

We should be getting paid for all this QA/QC work we are doing for ESRI

JoshuaBixby
MVP Esteemed Contributor

Regarding submitting bugs, I get your pain, and I consider myself fairly adept and experienced at doing it.  The real frustration happens after the bug is formally logged, then comes advocating for a fix and waiting, sometimes multiple releases.

As frustrating and time consuming as logging bugs can be, I encourage you to keep at it, not for Esri's benefit but for the sake of all the other software users out there.  And since Esri doesn't openly share all the bugs that are formally logged, even those sometimes that are fixed, I also encourage you to share the bug numbers back to the GeoNet community.

curtvprice
MVP Esteemed Contributor

Tyler, this is by design. You run into this issue when using two separate Desktop apps too (ArcMap, ArcCatalog, ArcScene etc).

For the software to see all changes, you'd have to be constantly polling the directory tree, and Esri has decided (I think rightly) to not tie up the app checking the tree for changes. Windows Explorer does this but even it doesn't do it constantly, and it has a lot less work to do that a catalog view does in ArcGIS. In Windows Explorer I enter F5 to refresh the view. The fix in ArcGIS is to refresh the catalog to force the gdbs/folders to be re-run. You have do to this if any application outside of ArcGIS messes with what is there, for example if Python runs an os command you need to have your script run arcpy.RefreshCatalog() to get things back in synch.

TylerSchwartz2
Occasional Contributor II

Thanks Curtis, thats some great insight into how Pro works and why I am seeing this behavior.  Sounds like this is a separate issue from the Project Folder bug outlined in my second post. 

A workaround to the file tree refresh issue is to use the Project Element Pane, adding the folder where your GDB resides, right clicking your GDB, refresh, and then dragging and dropping your feature class into your map.  I'll have to avoid the "Add Data" button from now on.  Thats assuming of course, that the Project Folder isn't bugged - but I believe that issue resides with Project Folders added as part of a  Project Template.  I guess you can always delete the project folder and re-add it.

RogerHelms
New Contributor II

   I had been scratching grooves in my head trying to figure out why I couldn't get the Feature Class to Geodatabase geoprocessing tool to copy a boundary set from one geodatabase to another geodatabase in ArcGIS Pro 2.1.2.   The tool reports success, and Windows Explorer updates its timestamps for the .gdb file, but the newly copied layer is nowhere to be found - the target database .gdf would come up as "This container is empty" when I tried to Add Data from it to the map.   

   But it turns out that the target geodatabase was receiving the new layer all along.  As soon as I exited ArcGIS Pro,  relaunched it and reopened my project, the new layer appeared and I was able to open it into my map. 

   I have to believe that I'm doing something wrong, or screwed up something in installing Pro to have to resort to that goofy workaround.  Can anyone think what?  Thanks.

ETA: Tyler, the original poster, later posted a follow up on his original post: 

"You need to manually refresh by right clicking on the folder/geodatabase and hit refresh. And yes, you need to do this every time something changes in your .gdb (or any file/folder) outside of Pro or you wont see it.  This is a known issue in Pro as it does not automatically update the catalog/folder tree as it does in most other Windows applications... .   you hit "F5" to refresh the view... ."   Here's the rest of that post of his:

 https://community.esri.com/message/750433-re-feature-classes-do-not-show-in-pro-catalog-tree?comment...   

0 Kudos
curtvprice
MVP Esteemed Contributor

I have run into this as well (2.1.2). Refresh did not help me, I had to close and open Pro to get content to update.

The Refresh really should work. 

AdamRepsher
Regular Contributor

I did not have this problem before upgrading to 2.2.0 yesterday.

Now when I run a model where I am placing the resultant Feature Class into a File Geodatabase and then calculating fields in that same Feature Class - I cannot find the Feature Class - cannot find it after Refreshing the FGDB - cannot find it after closing ArcGIS Pro‌ and opening it again.

All of the sudden, ArcGIS Pro is useless!

0 Kudos
ThomasColson
MVP Frequent Contributor

I have a suspicion: after running "placing the resultant Feature Class into a File Geodatabase and then calculating fields in that same Feature Class", do not close Pro, open Arc Catalog, connect to the FGDB, do you see the feature class and the result of the calculation?

0 Kudos