Labels do not display in ArcGIS Pro

8003
11
09-22-2020 09:48 AM
CraigEissler1
New Contributor II

#Labels are turned "on" and the Field is set; but labels do not display.

I'm working in ArcGIS Pro 2.5.4

What could be the problem?

Thanks!

Tags (1)
11 Replies
EricRizzo
New Contributor

There are a number of factors that may be affecting the display of your labels. Are there other other layers in your map display that are labeled? Did you create a label expression or are you simply trying to draw labels based on a single field? 

0 Kudos
CraigEissler1
New Contributor II

Simply trying to display labels based on a Field. There is nothing else on the map that needs labels.

Please share what some of these factors are that could cause simple labeling to not work - thanks!

0 Kudos
LukasFalk
Esri Contributor

Hello Craig, 

Like Eric pointed out there are a number of factors that could contribute to this behavior.  This can range from the Pro settings, Labeling settings, the data type, how it was generated, etc.  So you can understand how your question may be a bit difficult to address.  However I've got a few general things you could try.  

  • Try switching the labeling engine from Maplex to Standard.  This can be done by highlighting the feature layer in the Contents pane then open the Labeling tab at the top.  On the far right of this ribbon there is a More button and within it a setting titled Use Maplex Labeling Engine.  Uncheck this setting and refresh the map.  
  • You could attempt converting the labels to annotations to see if they appear.  This entails right clicking the layer in the Contents pane and click Convert Labels > Convert Labels To Annotation.  

If none of these workarounds provide the labels you need it may be worthwhile uploading the data to a shared drive and posting the link here.  That way I can bring it in on my end and get a better idea of what's going on.  If this is not possible, I've got some questions to try and narrow down the cause.  

  • What type of feature class are you working with and how was it generated?  What is it depicting?
  • Did you alter any of the label placement, positioning or sizing parameters?  Or did you simply turn on labels without messing with any other settings?
  • What is the field type for the field you are labeling with?  
  • What version of ArcGIS Pro are you in?  There is no 2.5.4 version.  The highest patch level for 2.5 is 2.5.2.  
  • Can you get any of the fields to label?  Can you get labels to work for a different feature class within the same project and if so, does bringing the troublesome layer into a fresh project alleviate the issue?

I hope this helps, 

Lukas 

0 Kudos
CraigEissler1
New Contributor II

Thanks for all those suggestions, Lukas

As it it turns out, a "class" was created for those Labels; then someone went in and removed them so it was no longer available to select!

-CE

0 Kudos
JustinBerke_CityOfCocoa
New Contributor

Check to see if the Pause button is engaged under the Labeling tab on the ribbon. It's nested in the Map group. I had my labels paused for... reasons and it was applied across subsequent map sessions.

JustinBerke_CityOfCocoa_0-1624366294425.png

 

rburke-bsrc
Regular Contributor

In case anyone else is here with this issue and none of the above worked, my problem was that I had a large graphic rectangle covering the map background (since I've found a bug that prevents background colors from being set). I shut off the graphic layer and the labels placed. You can fix the graphics presenting a barrier by going to the Labeling tab>Map group>More>Weights...>Graphic Layers tab and setting your graphics to None.

MillerWang
New Contributor II

For those none of the above worked, mine is two issues:

1. Too many labels to show, but my laptop is not fast, none discrete GPU. Although the right bottom corner "refresh" icon is stop rotating, the labels still didn't show up.

So I googled and arrived on this web page. After I read through, and return to my ArcGIS Pro 2.8, the labels showed up by itself!

2. A lower layer could cover up an upper layer! Yes, I saw with my own eyes. I re-order the two layers many times. The lower one will cover up the upper one!!!

MillerWang_0-1638667038873.pngMillerWang_1-1638667058153.png

 

0 Kudos
RachelSinclair
New Contributor

In case anyone else is here with this issue and none of the above worked, my problem was that my labels stopped drawing half way through a session (ArcPRO 2.9.1). I worked out that I had written an expression for my labels on my polygon dataset, then later on joined my polygon dataset to a table AFTER setting my label expression. The join to the table changed the names of the fields. For example, this expression [fieldName1]&" "&[fieldName2]

becomes

[datasetName.fieldName1]&" "&[datasetName.fieldName2]

so the labels no worker worked.

ChristyFung
New Contributor

My label doesn't show up even if I turned it on, my map has a lot of labels to show so it is running very slow, the label shows up sometimes but I have no luck so far keeping them until I export  the pdf.

0 Kudos