Select to view content in your preferred language

ImportError: DLL load failed while importing _arcgisscripting - after installing dbfread

3008
7
Jump to solution
06-02-2023 11:55 AM
DarrenConly
Occasional Contributor

Here's what happened:

  1. Made clone of arcgispro-py3 default env
  2. Entered conda install dbfread
  3. Got this warning

 

 

>conda install dbfread

The environment is inconsistent, please check the package plan carefully
The following packages are causing the inconsistency:

  - esri/win-64::arcgis==2.1.0.2=py39_14
  - esri/win-64::arcpy==3.1=py39_arcgispro_41759
  - esri/noarch::dask==2022.7.0=py_0
  - defaults/win-64::distributed==2022.7.0=py39haa95532_0
  - esri/noarch::ipykernel==6.16.0=py_1
  - esri/noarch::ipywidgets==7.7.2=py_0
  - esri/noarch::jupyterlab==3.4.8=py_0
  - esri/noarch::jupyterlab_server==2.16.0=py_1
  - esri/noarch::jupyter_client==6.1.12=py_0
  - esri/noarch::jupyter_console==6.4.2=py_0
  - esri/noarch::jupyter_contrib_core==0.4.0=py_0
  - esri/noarch::jupyter_contrib_nbextensions==0.6.0=py_2
  - esri/win-64::jupyter_core==4.6.3=py36_2
  - esri/noarch::jupyter_highlight_selected_word==0.2.0=py_4
  - esri/noarch::jupyter_latex_envs==1.4.6=py_5
  - esri/noarch::jupyter_nbextensions_configurator==0.4.1=py_3
  - esri/noarch::jupyter_server==1.21.0=py_0
  - esri/noarch::nbclassic==0.4.8=py_0
  - esri/noarch::nbclient==0.7.0=py_3
  - esri/noarch::nbconvert==7.2.1=py_2
  - esri/noarch::nbformat==5.6.1=py_0
  - esri/noarch::notebook==6.4.12=py_0
  - esri/noarch::notebook-shim==0.1.0=py_0
  - esri/win-64::pro_notebook_integration==3.1=py39_12
done

## Package Plan ##

  environment location: C:\Users\dconly\AppData\Local\ESRI\conda\envs\arcgispro-test

  added / updated specs:
    - dbfread


The following NEW packages will be INSTALLED:

  dbfread            pkgs/main/noarch::dbfread-2.0.7-pyhd3eb1b0_0
  pywin32            pkgs/main/win-64::pywin32-305-py39h2bbff1b_0

The following packages will be UPDATED:

  ca-certificates                               2020.7.22-0 --> 2023.01.10-haa95532_0
  certifi                          2022.9.24-py39haa95532_0 --> 2023.5.7-py39haa95532_0
  jupyter_core              esri::jupyter_core-4.6.3-py36_2 --> pkgs/main::jupyter_core-5.3.0-py39haa95532_0
  python                              esri::python-3.9.16-0 --> pkgs/main::python-3.9.16-h6244533_2

The following packages will be SUPERSEDED by a higher-priority channel:

  openssl                             esri::openssl-3.0.7-0 --> pkgs/main::openssl-1.1.1t-h2bbff1b_0

 

 

 

I chose to ignore the error and proceed with the install. But after installing and trying to import arcpy, I get this error:

 

 

>>> import arcpy
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "C:\Program Files\ArcGIS\Pro\Resources\ArcPy\arcpy\__init__.py", line 77, in <module>
    from arcpy.geoprocessing import gp
  File "C:\Program Files\ArcGIS\Pro\Resources\ArcPy\arcpy\geoprocessing\__init__.py", line 14, in <module>
    from ._base import *
  File "C:\Program Files\ArcGIS\Pro\Resources\ArcPy\arcpy\geoprocessing\_base.py", line 14, in <module>
    import arcgisscripting
  File "C:\Users\dconly\AppData\Local\ESRI\conda\envs\arcgispro-test2\lib\site-packages\arcgisscripting\__init__.py", line 131, in <module>
    from ._arcgisscripting import *
ImportError: DLL load failed while importing _arcgisscripting: The specified module could not be found.

 

 

 

This error did not happen prior to installing dbfread. Based on this March 2023 post and this August 2022 post, I figured it might have been related to not installing from the correct conda channel. But in the past I've installed dbfread in environments in this manner without any effects on arcpy. But for your all's information, here's the info on the dbfread install:

 

 

# packages in environment at C:\Users\dconly\AppData\Local\ESRI\conda\envs\arcgispro-test2:
#
# Name                    Version                   Build  Channel
dbfread                   2.0.7              pyhd3eb1b0_0

 

 

 

Other observations:

  • I'm using Pro 3.1
  • This issue doesn't seem to care what package I'm installing (I use dbfread as an example, but it also affected me for geopandas).

Any idea what's going on?

Tags (4)
0 Kudos
1 Solution

Accepted Solutions
DarrenConly
Occasional Contributor

Problem solved!

The solution, after working with ESRI tech support, was doing a somewhat more involved uninstall-reinstall (I had tried simply re-installing without doing an explicit uninstall and that didn't work). Image below shows the steps we did:

DarrenConly_0-1686264602356.png

So I think my original issue was due to some bug with the specific installation I had. Either way am glad it's fixed!

 

View solution in original post

7 Replies
DarrenConly
Occasional Contributor

As an update, I tried installing geopandas through Pro's package manager, thinking that doing so would get rid of conflicts (i.e., choose the correct conda channel, not override any esri-sourced packages, etc.). But alas this also resulted in "DLL load fail" error.

I also tried all of the above on a different machine: While it did not give me the long warning, arcpy stopped working after installing dbfread.

DarrenConly
Occasional Contributor

Problem solved!

The solution, after working with ESRI tech support, was doing a somewhat more involved uninstall-reinstall (I had tried simply re-installing without doing an explicit uninstall and that didn't work). Image below shows the steps we did:

DarrenConly_0-1686264602356.png

So I think my original issue was due to some bug with the specific installation I had. Either way am glad it's fixed!

 

John_Herrera
New Contributor III

Thanks for the solution!  Problem solved.

0 Kudos
Pagdaemonium
New Contributor

After updating ipykernel from within the package manager, which triggered upgrades to python 3.9.16 and jupyter lab, importing arcpy is now failing.  Previously, I had a similar issue with importing arcpy and reinstalled arcgispro 3.1.2 and fixed it.  From that point I cloned the default environment and added a few additional packages without issues.  I assumed the package manager would be a "safer" place to add/update packages without breaking the environment for arcpy, but apparently that is not the case. What is the deal with the error: "ImportError: DLL load failed while importing _arcgisscripting: The specified module could not be found."  The module does exist.

ShariF
by
New Contributor III

I am having the same issue. Using arcgis pro 3.1.4 and using the cloned environment because I had to add packages. Did you find a solution? 

John_Herrera
New Contributor III

Yes, the problem was our firewall blocking the request when updating Python packages.  Our ISO had to white-list a bunch of entities.  Once white-listed, I was able to update the packages.

0 Kudos
MinhazulIslam919
New Contributor II

Hi, I also have the same issue. It is frustrating. Did anyone get around to this problem? I installed Geopandas (using the ArcGIS Pro package manager) and am now getting a DLL error for importing both the "arcpy" and "geopandas" libraries. 

0 Kudos