Help Request: AGP to AGOL 'Publishing web layer failed'

675
5
02-17-2021 10:09 AM
Labels (1)
NigelRothwell
New Contributor II

Hello All,

I am trying to publish a web layer from ArcGIS Pro to ArGIS Online. I've done this successfully before in AGP2.5, but haven't used the software for some months, so am trying to get back up the learning curve.

This ought to be straightforward - it is a georeferenced raster map which I want to publish as a Tile to overlay on a basemap in an AGOL project. Consistently I am getting a 'Publishing web layer failed' message - see screenshot attached. Frustration is now getting the better of me - steps I have tried:

  • There aren't many variables to play with in Share as a Web Layer, but I've tried changing the tiling scheme, the level of detail, caching on the server and caching locally
  • I've also tried to publish a different georeferenced map, and to share as a Web Map
  • I've done a complete reinstall of AGP2.7.1
  • Suspecting a corrupted gdb I've created a new blank project and downloaded my reference basemap from the AGOL project to make sure I'm using the same projection and coordinate system.

But I'm still getting the same message - feels like there must be something really basic that I am missing, so grateful for any suggestions.

Many thanks,

Nigel

0 Kudos
5 Replies
JonahLay
Esri Contributor

Hi Nigel,

It looks like you configured the web tile layer to cache locally. Can you try using the Create Map Tile Package GP tool to create the tile package? Next, use the Share Package geoprocessing tool (check Publish web layer) to share the web layer. Does it work this way?

After you try this, it may still be best to contact technical support so that they can take a closer look.

Best,

Jonah

NigelRothwell
New Contributor II
Many thanks Jonah. I initially thought you had solved my problem - for
which my grateful thanks. I have used your suggested workflow and it worked
fine for my first file, so to test and check - I followed through exactly
the same flow with my second file and that triggered a 999999 bug report
error - so I've escalated to technical support.

But I haven't left it there - I've tried to understand what and why, and
have now isolated that the only difference (other than file name and size -
they are both relatively small files anyway) is the Maximum level of detail
parameter set.

I'll see what Esri come back with.
Thanks again.
Nigel
0 Kudos
jcarlson
MVP Notable Contributor

I also encountered this issue a number of times in the past, where the service definition seemed to upload fully, but failed at the "Publish" step right at the end.

I could never quite figure out why it seemed to happen some of the time, but not consistently. It sounds like you've tried all the usual steps, too. Is it possible for a coworker or other user to attempt the same process with a different username?

- Josh Carlson
Kendall County GIS
0 Kudos
NigelRothwell
New Contributor II

Definitely worth trying Jonah's suggested workflow - it got me part way there, before triggering a bug report error.

0 Kudos
AnyerlinaHernandez
New Contributor II

Hi, have you foun the solution to 'Publishing web layer failed' error? 

I'll appreciate your answer. 

0 Kudos