Geotagged Photos to Points - different results in Arcpy than Geoprocessing tool?

01-27-2021 07:56 AM
Labels (1)
New Contributor III

I have a folder with geotagged photos from a DJI drone that I am trying to use the Geotagged Photos to Points tool. It is working perfectly, except I get different results when I run the process in Arcpy than when I do it through the geoprocessing tool.

When I run the following code (in a Notebook), there is only one point that corresponds with the last photo. However, each photo/line in the attribute table is also located at that point:


folder = 'Z:\\folder'#folder with the photos in it
outputGDB = r"G:\\geodatabase.gdb\\" #full file path of geodatabase where point FC will be stored
FLID = '339'#flight ID

gtphoto =, outputGDB + "FLID_" + FLID, None, "ALL_PHOTOS", "ADD_ATTACHMENTS")



However, when I go into my geoprocessing history and pull up the Geotagged Photos to Points tool I just ran, delete the point FC, and rerun the tool, it works the way it should. I get a point file with a point for each photo where they should be.

Why are the results different when I run the tool in Notebooks than in the geoprocessing window when the parameters are the same? Bug, or issue with code?

0 Kudos
1 Reply
Esri Frequent Contributor

Ryan, the only way I know how to run this is as I describe in this essay, below:


But hopefully someone else here in GeoNet will be able to help you further.

--Joseph Kerski

0 Kudos