Failled to publish web layer

10791
19
11-30-2017 08:45 AM
WyllyKHOMBILA
New Contributor III

Hello,

I would like to publish web layer  from Pro 2.0 to Portal 10.5.

But I have this error "Failed to publish web layer"


Going to check the ArcGIS Pro logs into

C: \ Users \ useracount \ AppData \ Local \ ESRI \ ArcGISPro \ Staging \ SharingProcesses \

I have the error below :  the PubishingTools service could not initialize,  in ArcGIS Server:

"com.esri.arcgis.discovery.ejb.ArcGISServerEJBException: Could not initialize service 'System / PublishingToolsEx.GPServer'."

By checking this information in ArcGIS server, I see that the service has started successfully.

Please, anyone knows how to avert this error ? 

best regards

19 Replies
DerekLaw
Community Moderator

Hi Tadesse,

Apologies for the late reply. I have been out of the office on business travel the last few weeks.

> Has anyone got a solution ? I tried SQL server, CSV , xls and they all can not be published as a Map. 

Can you please provide more context/info on the details for your issue? You mention several different data sources - are you having problems accessing/adding this data in ArcGIS Pro? or just sharing them as web layers from ArcGIS Pro?

Thanks,

0 Kudos
JesúsGómez
New Contributor II

We have a similar problem.
We have ArcGIS Enterprise and we want to share from ArcGIS Pro a web layer as feature type. I review here the following points in case they can be useful to find a solution to the problem.

  • We want to share a layer from a local geodatabase. This geodatabase only has a few polygons.
  • We are testing with the administrator user, so we have all the permissions.
  • I choose the option "Copy all data" and when I press "Analyze". I don't get any error.Share As Web Layer options
  • When publishing, everything seems correct but finally ArcGIS shows the error "Failed to publish web layer".
    The SharingJobLog.log file has correct status messages but the last ones show:

2018-11-20 17:23:05    Status: InProgress    StatusMessage: Initialised Publication Tool    
2018-11-20 17:23:05    Status: InProgress    StatusMessage: Publishing web layer (AGO)    
2018-11-20 17:23:10    Status: InProgress    StatusMessage: Error when publishing web layer (AGO)    
2018-11-20 17:23:10    Status: InProgress    StatusMessage: Error when executing the publication tool    
2018-11-20 17:23:11    Status: Failed    StatusMessage: Failed to publish web layer    ErrorMessage: Failed to publish web layer

  • In Portal, "My Content" displays a "Service Definition" created with the item name but there is no a hosted feature layer.

In My Content I only see "Service Definition"

  • If in Portal I want to add the element from a shapefile or geojson of my team I get the error message: "Publish Service error: Access to this resource is not allowed".
  • PublishingTools GP service is ok.

Any ideas?

Thanks.

Jesus Gomez

0 Kudos
WyllyKHOMBILA
New Contributor III

Hello Jesus GOMEZ,

Which ArcGIS Enterprise version do you have?

Assuming that ArcGIS Server is federated and a database is registered as managed, I invite you to log to portal (Organization> modify settings> utility) and check that the following url is configured well: https : //webadaptor.domain.com/arcgis/rest/services/Utilities/PrintingTools/GPServer/Export%20Web%20Map%20Task).

If this URL is active, please restart the Publish Service in ArcGIS Server and check the ArcGIS Server log file and share the resulting message.

Hope this helps

JesúsGómez
New Contributor II

Hi Wylly KHOMBILA.

Our version is ArcGIS Enterprise 10.6.1
ArcGIS Server is federated and a database is registered as managed.
The URL of my print service is this but I see that it displays an error message: "Unable to reach the print service".


This is the ArcGIS Server log. I see several errors.

Thanks.

WyllyKHOMBILA
New Contributor III

Hi Jesus GOMEZ,

 

Please make sure that ArcGIS server is very well federated:

log in portal, my organization> setting> servers

and change the URL of the ArcGIS server. It must be as such:

 https://webadaptor.domain.com/arcgis

(arcgis is the IIS name of arcgis Server services)

save the changes and check again if the printing error has disappeared.

As for the ArcGIS server log, it shows errors in the registration of both databases including ArcgisDataStore.

I propose you first solve the first error message and see the next one together.

JesúsGómez
New Contributor II

Hi Wylly KHOMBILA,

We have two federated servers: one that works and one that doesn't (the IP server).
The severe warnings in the log correspond to that federated server that doesn't work. We've already unfederated it and we don't have any messages in the log.
Also, we have already corrected the URL of printing service.

Now this service works correctly but we still have the same problem in ArcGIS Pro: "Failed to publish web layer" (attach log file). And from Portal: "Publish Service error: Access to this resource is not allowed".

Thank you

WyllyKHOMBILA
New Contributor III

Hi Jesus GOMEZ,

Sorry for the late response.

can you refresh the connection to your managed database in the ArcGIS Server data store?

waiting for your feedback,

0 Kudos
JesúsGómez
New Contributor II

Hi Khombila,

I'm sorry it took me so long to answer you. Thank you very much for your feedback.
I have been checking my data stores and the status is OK on all.

I have already fixed configuration errors but I still can't publish from ArcGIS Pro. The log now shows this:

2018-11-28 21:37:58    Status: InProgress    StatusMessage: Publishing tool initialized    
2018-11-28 21:37:58    Status: InProgress    StatusMessage: Publishing web layer (AGO)    
2018-11-28 21:38:12    Status: InProgress    StatusMessage: Error while loading
2018-11-28 21:38:13    Status: InProgress    StatusMessage: Publishing tool execution failed        
2018-11-28 21:38:13    Status: Failed    StatusMessage: Failed to publish web layer    ErrorMessage: Failed to publish web layer

When I clicked Analyze: No errors or warnings found.

I can create databases from ArcGIS Pro but I can't publish layers. Also, I can publish layers from shapefile or geojson from Portal.

Thank you for your help.

----------------------------------------

UPDATE

We believe that the problem may be caused by some conflict with residual data already stored. The other problems are already solved.
Is there any way to completely empty the contents of the data store?

0 Kudos
WyllyKHOMBILA
New Contributor III

Hi GOMEZ,

So, could you well before the suppression of the data proceed to the following actions:

  • Restart the ArcIS Server and Portal;
  • Rename the data you want to publish from ArcGIS Pro to portal
  • download / install the Fiddler utility on your computer
  • Launch this utility at the same time as the service publish attempt on ArcGIS Pro.

Deleting data can be done in ArcGIS Server or directly via ArcGIS pro.
to do this you should log into admin via the server URL and delete the data from the Hosted folder.

for exemple : 

You will also find administration batches of the data store in the following tool folder:
  C: \ Program Files \ ArcGIS \ DataStore \ tools

kind regard

JesúsGómez
New Contributor II

Thank you KHOMBILA,

I'll follow your instructions.

kind regard

0 Kudos