Exporting Feature Class with GlobalID from Enterprise SDE to a table, globalID's are removed

710
7
Jump to solution
10-28-2018 10:13 PM
BenVan_Kesteren1
Regular Contributor

I have a Rubbish_Bins feature class in my SDE, this has GlobalID (type is Global ID) column as per below screenshot:

You can see all the global ID's are populated.

I then run the Copy Rows tool in Arc Pro (right click | data | export table):

I open this CSV and I note the global ids are all removed, yet all other columns are populated.

I then tried testing this in ArcMap 10.6.1

I open the attribute table, click export, then use these settings:

Then i get this error:

Note this error is only happening on this feature class (its the only one I have added GlobalID to).

Am I doing something wrong here or is this a bug?

Thanks

0 Kudos
1 Solution

Accepted Solutions
BenVan_Kesteren1
Regular Contributor

I have spoken with ESRI and they have confirmed this is a bug in the tool, and hopefully is rectified in the future.

Cheers

View solution in original post

7 Replies
Asrujit_SenGupta
MVP Regular Contributor

To confirm that, just add GlobalID to some other data and test the same workflow. Could be data specific (or maybe not)

0 Kudos
BenVan_Kesteren1
Regular Contributor

I have spoken with ESRI and they have confirmed this is a bug in the tool, and hopefully is rectified in the future.

Cheers

View solution in original post

Asrujit_SenGupta
MVP Regular Contributor

Maybe just share the Bug details here, for reference, in case someone else comes across the same issue.

0 Kudos
BenVan_Kesteren1
Regular Contributor

I can see the bug is logged in my.esri.com support page, it says "#BUG-000117958 GlobalID's are set to zero when using Copy Rows tool in ArcGIS Pro with data coming from an Enterprise SQL Server Geodatabase"

I am unsure how to link it here? How do I find it for others to see?

Asrujit_SenGupta
MVP Regular Contributor

It doesn't seem that there is a public link to share yet. Normally you can search for Bugs here: Esri Support Home 

0 Kudos
JeanineEGS
New Contributor II

I just got this as well.

Export from Arc Pro filegdb  export table to csv in a folder and global-id s all go Zero.

If I export to .dbf then they are preserved.

I need to csv to append /update  new data in AGOL and wanted to preserve the Global_ID.

 

Any news on the fix?

JessicaJThompson
Occasional Contributor

I am wondering the same thing. It is still doing this as of today - October 2021.

0 Kudos