Error joining csv file to feature class

05-02-2022 11:32 PM
New Contributor

Hello, as the title says I am trying to join a CSV file to a feature class and I keep getting an error 999999. At first, I thought it was because field types were different so once I had them matching up properly I assumed the join would go through, but I still get the same error. It should be a fairly simple join so I am not sure what I am missing that is causing this error to come up. I would appreciate any advice on the matter.

Tags (1)
4 Replies
MVP Esteemed Contributor

show your inputs.  it could be something with a particular column or a row.

Try making the csv into a geodatabase table first, then try the join is another option

... sort of retired...
0 Kudos
Frequent Contributor III

If you are trying to join string fields together make sure your .csv file does not have a length greater than 255

If it does then technically even though it is still a string but it is a type not supported.  One way to determine that is to import the .csv into a database and look at the properties.  .csv fields can have up to 32767 characers.


0 Kudos
New Contributor III

Like DanPatterson said, add your csv to the Contents pane and then immediately export it to a geodatabase table.  Joining a Feature Class to a csv file directly is prone to errors, which is why everyone recommends exporting the csv to a geodatabase table.  If you join a Feature Class to a csv and check the "Index Joined Fields" checkbox, you will always get a ERROR 999999.

It would be nice if we had better error messages when joining Feature Class to a csv. ESRI should disable the ability to join Feature Class to csv altogether.  Having a right click option to import CSV to Geodatabase table quickly would be a nice alternative.


Esri Contributor

FYI, added a validation error to let users know text files do not support indexing.  I hope this helps for users in 3.2+