Editing 3D features

685
5
Jump to solution
11-18-2020 10:24 AM
Labels (1)
ellen_fehrs
New Contributor II

I am trying to edit z-enabled lines (representing hydro flowpaths) in Arc Pro. I used the Interpolate Shape tool to give my flowpaths the same z-values as my elevation surface (LAS files, in this case). I need to manually edit the elevations at culvert/bridge crossings.

I've tried creating new z-enabled line features and snapping them to my existing geometries, but I can't get the Z Mode tool (Edit > elevation group > Z Mode) to let me "bring over" the elevation values from my surface. The "Surface" option is completely grayed out in my Map and Scene views, and it only allows me to select "Constant."

How do I access the "Surface" option from the Z Mode tool? I feel like I've tried so many things, but it remains grayed out.

0 Kudos
1 Solution

Accepted Solutions
Scott_Harris
Esri Regular Contributor

@ellen_fehrs 

Did you add an elevation source to your map or scene, here is the doc on it: https://pro.arcgis.com/en/pro-app/help/mapping/properties/elevation-surfaces.htm

relevant section:

sharris_0-1605726706469.png

 

 

Does this help?

Thanks,

Scott

View solution in original post

5 Replies
Scott_Harris
Esri Regular Contributor

@ellen_fehrs 

Did you add an elevation source to your map or scene, here is the doc on it: https://pro.arcgis.com/en/pro-app/help/mapping/properties/elevation-surfaces.htm

relevant section:

sharris_0-1605726706469.png

 

 

Does this help?

Thanks,

Scott

ellen_fehrs
New Contributor II

I am able to add DEM's as an elevation source, but it won't let me add LAS files. Are LAS files not an option? I'd rather not use the DEM--I'd like to use the "least processed" Lidar product. Would this work if I converted my LAS files to a TIN?

But, yes, when I did add the DEM's as an elevation source, it did enable the Surface option for Z Mode editing. So thank you! You've already helped me so much! (:

0 Kudos
ellen_fehrs
New Contributor II

I just realized how dumb my second question was, because I'm trying to get elevation values from a surface and LAS point clouds are not surfaces, haha.

Sorry to waste your time, Scott, you have been enormously helpful! 

CarlJung1
New Contributor

This solution does not fix the problem.  This is preventing me from creating a 3D line for a profile on my raster.

  I have the same problem after adding a custom elevation source from a DEM. I added the elevation source and made a surface from the source according to the instructions, but the surface tab is grayed out. I cannot use the Portal surfaces, because I am using a raster from Bathymetry. An extra is that I used absolute value on the bathymetry and inverted the raster to place the raster above sea level, so it is not underground navigation related.

0 Kudos
CarlJung1
New Contributor

Hi Again, the solution for me was to go to map mode.  You cannot add the line notes and change the line tools properties in the local scene tab.

0 Kudos