Create Tile Package stuck at 100% for hours

1367
10
06-10-2020 12:26 PM
MelissaDaniels1
New Contributor III

I'm trying to create a tile package in ArcGIS Pro to use on a Collector map. I'm using clipped NAIP imagery. It keeps getting stuck at 100% for hours and not completing. I've tried leaving it overnight. It has all the required things: pyramids, a map description, etc. I've tried restarting Pro and restarting my computer. I can't figure out what could be preventing it from completing and would very much appreciate any suggestions. My Pro version is current.

Thanks!

10 Replies
ReinhardtBotha
New Contributor II

I have the same problem, trying to create a Map Tile Package from a few vector layers and the Create Map Tile Package tool is stuck at 100% for hours with CPU usage on 100%. I have ArcGIS Pro 2.5.2.

DavidPike
MVP Frequent Contributor

Have you considered creating a Tile Cache instead? I prefer it as I can control the tile generation in batches.

0 Kudos
GarimaTiwari
Esri Contributor

Reinhardt Botha Melissa Daniels‌ 

Is it possible for you to share the data that can be used to reproduce this issue? If so, would you please open a support ticket and provide details. 

Please ensure you have disk resources available and the NAIP imagery renders at the level requested.

0 Kudos
MichaelKlassen
New Contributor

I have the same issue. I've tried a tile cache and tile package. For some reason when it gets to 100% it just sits there. I am also using some NAIP imagery, but I do not believe this is the cause. 

0 Kudos
AzharIbrahim
New Contributor III

I have the same issue with manage cache tiles--it gets to 100% and stops. I can leave it for days and the files do not change. I've started going through a couple of levels at a time to see where it starts getting stuck. No error messages are displayed. I'm using a mosaic dataset with overviews and analysis runs fine without errors.

MollyReynolds1
New Contributor

Did anyone find a solution? I'm running Manage Tile Cache in Pro 2.8.2 and it's also getting stuck at 100% with high CPU usage. I'm also using clipped NAIP imagery... a .jp2 file in an MXD.

Edit: it may have to do with the .jp2 file type: https://support.esri.com/en/technical-article/000008788

I exported to a tif and was able to run Manage Tile Cache with no issue.

0 Kudos
NedCake1
New Contributor III

I'm having the same problem with the Create Map Tile Package tool. In my case, I'm generating tiles of a topo contour layer in lods 14-19. This map is a single vector layer with scale base rendering and labeling. I've watched resource monitor as the process writes the tile bundles.  It finishes writing the tiles in about 2 hours then does nothing. Stuck at 100% for 24 hours plus or until I give up and kill the job. 

CharlesHardy1
New Contributor II

I'm having the exact same issue in version 2.9.2.  The task starts and gets to 100% in about 25 minutes but now it has been sitting at 100% with the last message line in the details being " Creating tile package using 4 parallel instances."  for the last 18 hours.

0 Kudos
MR14
by
New Contributor

Same here. I've used the tool "generate tile cache tiling scheme" and after that "create map tile package". With a small Maximum level of detail (e.g. 6) it finishes in a few minutes. With a maximum level of 16 it takes 40 hours and does not finish

0 Kudos