Catalogue pane can't see items in Geodatabase

463
4
05-21-2021 09:06 AM
Labels (2)
DavidJohnstone
New Contributor

In the catalogue pane in ArcPro I cannot see inside a feature dataset. I know there are feature classes there because I can drag and drop them onto a map. Has anyone else had this issue. I'm using version 2.8.0-Thanks

0 Kudos
4 Replies
ToddMetzler
Occasional Contributor II

Newly created content?  Do you see the same result when viewing in Catalog View?The ArcGISIndexingServer and ArcGIS Pro User profile defined Options > Indexing settings can cause content to not show up depending on the settings.  

0 Kudos
DavidJohnstone
New Contributor

Hello Todd

Yes the result is the same in catalogue view. I haven't changed anything in the user profile, but I have than updated to the latest version.

If I make a new feature class, it appears automatically on the map, but can't be seen in the catalogue view

If I copy a feature dataset and paste special into a new gdb the feature classes can be seen, however I cannot do this for feature classes not in a feature dataset because I can't see them. If I copy and paste the whole database it has the same problem. If I try and export feature class to geodatabase it doesn't pick up the feature classes.

If I look at an old backup on an external drive it has the same problem although when I made the backup it didn't have this problem, its only been in the last week. I'm thinking maybe a file is missing or has been deleted in error

So I have a partial solution with copy and paste special and I have the other datasets so just a bit of extra work required

0 Kudos
JayantaPoddar
MVP Esteemed Contributor

What happens when you refresh the parent geodatabase or restart ArcGIS Pro? Does the issue persist in  a new ArcGIS Pro Project?



Think Location
0 Kudos
DavidJohnstone
New Contributor

Hello Jayanta

Refreshing/restarting has no effect. Also previous backups of the project have the same problem even though they didn't have the issue when the backups were made.  If I add a .gdb from a different project into the catalogue pane I can see the different datasets within it, so the problem is only with this particular gdb.  If I create a completely new project it does not have this problem

0 Kudos