Can't select multiple features in map

459
9
10-04-2021 12:03 PM
Labels (2)
JoeBorgione
MVP Esteemed Contributor

Using ArcGIS Pro 2.7.4, I cannot interactively select multiple features in a map.  When I hold the shift key down with the select tool selected it zooms in.  Is there a hot key setting I need to turn off?

In my gif below, I select one street segment, clear the selection and then select the adjacent segment and clear. Then with the first segment selected, I hold down shift and when I try to select the second segment, it zooms in.ShiftNoWorkee.gif

 

 

That should just about do it....
0 Kudos
9 Replies
rburke-bsrc
Regular Contributor II

@JoeBorgione  Do you have Webroot antivirus by chance? In our organization, the identity shield setting was causing some bizarre issues with the cursor and the select/zoom/navigate tools.

Info: https://community.esri.com/t5/arcgis-pro-questions/uncontrolled-zoom-out-on-layout-view-arcgis-pro/m...

JoeBorgione
MVP Esteemed Contributor

Thanks for the reply, @rburke-bsrc but alas we don't deploy Webroot.  The post you link above mentions a bug, but that was in ArcMap.

That should just about do it....
0 Kudos
DanPatterson
MVP Esteemed Contributor

Joe, you don't have the Explore tool active by mistake, since that does a center zoom in.

shift with the Selection tool should do what you want, but have a read of the shortcuts

ArcGIS Pro keyboard shortcuts—ArcGIS Pro | Documentation


... sort of retired...
0 Kudos
JoeBorgione
MVP Esteemed Contributor

It seems to be a computer specific problem;  it works as expected on my laptop.  The past few weeks with ArcGIS Pro have been brutal.  I've uninstalled and downgrade, upgraded (and repeat) several times and keep finding new problems.

But as I like to say:

That should just about do it....
0 Kudos
AndyWells
Occasional Contributor II

I am also having this same behavior. The explore tool is definitely not enabled. If I move the arrow over the feature I am selecting, hold shift and do not move the mouse at all, I can select without zooming in. But if I move the mouse even a tiny bit, the zoom rectangle appears. Very frustrating. 

0 Kudos
rburke-bsrc
Regular Contributor II

One of my colleagues is having similar issues with explore/select/zoom tools just in the last few weeks - wonder if something broke.

0 Kudos
by Anonymous User
Not applicable

Same issue here from time to time. Restarting my computer seems to fix it for me.

0 Kudos
WillPlatt
New Contributor III

I just had this issue happen to me.  I clicked back over to Explore then clicked back to Select and that seemed to fix it.

0 Kudos
MattGoodman1
New Contributor III

This is currently happening to me (again) with ArcGIS Pro 3.0.

0 Kudos