ArcGIS Pro Update (2.5.1) Partially Broke the Register with Geodatabase Tool

256
2
Jump to solution
05-12-2020 08:19 AM
RyanUthoff
Occasional Contributor III

I have recently updated to the latest release of ArcGIS Pro (2.5.1) and it has partially broken the Register with Geodatabase tool.

While non-spatial tables continue to register fine, I am no longer able to register spatial tables with the geodatabase. I originally found this issue when attempting to use my Python script to register the tables, but I was also able to replicate this behavior when using the tool within ArcGIS Pro as well. I received two variations of the same error message, one through ArcGIS Pro, and one when my Python script fails. I've attached those error messages.

I reverted back to ArcGIS Pro 2.5 and the Register with Geodatabase tool works again (on the exact same table in the same database I was trying to previously register). I was able to replicate this behavior in two different environments as well. It looks like ArcGIS Pro 2.5.1 is a no go for us until this issue is resolved. The tables we are trying to register are within a Microsoft SQL database.

0 Kudos
1 Solution

Accepted Solutions
RyanUthoff
Occasional Contributor III

I opened a case with Esri support and they were able to replicate the issue and confirmed it is a software defect. For anyone else who encounters this bug, it is: BUG-000130888: Register with Geodatabase - Error 999999: Something unexpected caused the tool to fail.

View solution in original post

2 Replies
George_Thompson
Esri Frequent Contributor

I would recommend creating a technical support case to get a formal defect logged.

--- George T.
0 Kudos
RyanUthoff
Occasional Contributor III

I opened a case with Esri support and they were able to replicate the issue and confirmed it is a software defect. For anyone else who encounters this bug, it is: BUG-000130888: Register with Geodatabase - Error 999999: Something unexpected caused the tool to fail.

View solution in original post