ArcGIS Pro takes 20 minutes to startup

767
9
Jump to solution
11-17-2021 08:20 AM
ArnieWaddell1
New Contributor III

ArcGIS Pro takes 20 minutes to startup and can not figure out how to fix it.  Should I reinstall?

0 Kudos
1 Solution

Accepted Solutions
jcarlson
MVP Honored Contributor

If it happens outside of a project, it could still be a data connection. Do you have anything in your Favorites list in your Catalog?

Between your "slow machine" and the lower-spec laptop, are there differences with where the program is installed, or any other user settings?

My desktop machine used to be very slow with certain aspects of Pro because it was trying to save / backup items to a network location rather than on the local machine. Going through all my application settings and making sure everything was local significantly improved things.

- Josh Carlson
Kendall County GIS

View solution in original post

0 Kudos
9 Replies
DanPatterson
MVP Esteemed Contributor

maybe

windows add/remove programs, selrct remove, then Repair


... sort of retired...
jcarlson
MVP Honored Contributor

Does it take this long to open any project? Is Pro accessing any resources over a network that could slow it down?

Try opening the ArcGIS Diagnostic Monitor (Ctrl + Alt + M) and see if there is anything going on there.

- Josh Carlson
Kendall County GIS
RobertBorchert
Frequent Contributor III

Just start up or start up a project. 

Can you share with us your hardware specs?

Most likely it is hardware, your connections to the data, or your Project is much to complicated. 

0 Kudos
ArnieWaddell1
New Contributor III
I am not opening a project. It is just opening up Pro. On my laptop with lower specs, it opens up in 30 secs


0 Kudos
DanPatterson
MVP Esteemed Contributor

perhaps

ArcGIS Pro Performance Assessment Tool—ArcGIS Pro | Documentation

one of its functions .... View metrics for ArcGIS Pro startup times, as well as loading times for maps and bookmarks.


... sort of retired...
0 Kudos
VMitch
by
New Contributor III

Agree with RobertBorchert, most likely hardware and the connections to the data. It happens from time to time for myself. 

0 Kudos
ArnieWaddell1
New Contributor III
I am not opening a project. It is just opening up Pro. On my laptop with lower specs, it opens up in 30 secs




0 Kudos
jcarlson
MVP Honored Contributor

If it happens outside of a project, it could still be a data connection. Do you have anything in your Favorites list in your Catalog?

Between your "slow machine" and the lower-spec laptop, are there differences with where the program is installed, or any other user settings?

My desktop machine used to be very slow with certain aspects of Pro because it was trying to save / backup items to a network location rather than on the local machine. Going through all my application settings and making sure everything was local significantly improved things.

- Josh Carlson
Kendall County GIS
0 Kudos
ArnieWaddell1
New Contributor III

Your answer put me on the right track.  It was my  add ons were set to search a network for some reason.  Once I removed it, it loaded in 15 seconds.  Thx