AcGIS Pro 2.8.2: The label of a polygon appears in other polygons despite the level of zoom,

461
11
11-15-2021 01:48 AM
JamalNUMAN
Esteemed Contributor

AcGIS Pro 2.8.2: The label of a polygon appears in other polygons despite the level of zoom,

 

In the screenshot below, I couldn’t figure out why label 30 still appears in all other polygons despite the level of zoom. In return, label 10 performs correctly.

What could be the issue here?

 

The data is attached

 

Clip_1124.jpgClip_1122.jpgClip_1123.jpg

 

Clip_1125.jpg

----------------------------------------
Jamal Numan
Geomolg Geoportal for Spatial Information
Ramallah, West Bank, Palestine
0 Kudos
11 Replies
DanPatterson
MVP Esteemed Contributor

Are you using the Maplex labelling engine ?  (which you should be)

and if so, what labelling properties did you specify?

Label with the Maplex Label Engine—ArcGIS Pro | Documentation


... sort of retired...
JamalNUMAN
Esteemed Contributor

This is the default labeling as the layer is added to Pro with no settings at all at any level.

 

The behavior in ArcMap is correct and as expected even if when the maplex is activated

 

Is this a bug?

 

Clip_1129.jpgClip_1130.jpgClip_1131.jpg

----------------------------------------
Jamal Numan
Geomolg Geoportal for Spatial Information
Ramallah, West Bank, Palestine
0 Kudos
JayantaPoddar
MVP Esteemed Contributor

Try choosing a suitable Label Placement option.

JayantaPoddar_0-1636985320461.png

 



Think Location
JamalNUMAN
Esteemed Contributor

Hi Jayanta,

 

If you keep zooming, label 30 will appear in side the polygon.

 

I tried all the options but none of them worked for me?

 

Is this by design? Bug? Sort of settings?

 

 

Clip_1146.jpgClip_1147.jpg

----------------------------------------
Jamal Numan
Geomolg Geoportal for Spatial Information
Ramallah, West Bank, Palestine
0 Kudos
DanPatterson
MVP Esteemed Contributor

it is the "may place label outside polygons bounds" ... it doesn't say it "will place...."


... sort of retired...
0 Kudos
JamalNUMAN
Esteemed Contributor

Unchecking “may place…” option doesn’t resolve the issue as per the screenshot below

 

Clip_1167.jpg

----------------------------------------
Jamal Numan
Geomolg Geoportal for Spatial Information
Ramallah, West Bank, Palestine
0 Kudos
DanPatterson
MVP Esteemed Contributor

the polygons don't overlap do they?

If you tried it in Pro 2.9 and it is still the same, then

send your data to Tech Support for resolution


... sort of retired...
JayantaPoddar
MVP Esteemed Contributor

On running Check Geometry, I could see a lot of self-intersecting polygons and short segments. This could be the reason the labels overrun to adjacent polygons.

Could you run Repair Geometry (on a copy of feature class), and check if the issues persist.



Think Location
JesseWickizer
Esri Contributor

I confirmed with the provided dataset that after repairing geometry the label is placed correctly as long as the "Avoid holes in polygons" option is checked.