Troubleshooting loading layer from Google Sheets

990
2
05-11-2022 11:37 AM
Labels (2)
MattJ
by
New Contributor

I am loading feature services from a Google Sheets workbook. I have them all already, though I had to reformat a few with new schemas and therefore had to delete them. When going to generate the new items in Online, I choose the workbook but am then confronted with this error message:

"Error while analyzing file - There was an error trying to analyze your file. Please check your file is formatted correctly."

The only thing I changed with my workbook was deleting some columns and adding a few new ones. Is there some way to properly troubleshoot this issue? What's going on?

2 Replies
GabrielFM
New Contributor

I had probs tonight with this. Did you ever get it fixed? It's not working for me.
I made a copy of the sheet to troubleshoot it and eventually got to the next part through trial and error (I had some blank lines, which I think fixed it). 
Now I get through the wizard and there's a red box in the upper right corner that says !undefined x

Ok? What is undefined?

 

 

0 Kudos
JonSchull
New Contributor II

I'm having exactly these problems:

1) a feature layer that I have been routinely updating for days began to hang at "adding item"

2) I created a new layer and got "Error while analyzing file - There was an error trying to analyze your file. Please check your file is formatted correctly."

3) I reverted the gSheet to an earlier version that had updated previously and tried to create a new feature layer.  I get "undefined". 

  • And the layer shows no data
  • And yet when I download the data from the layer as xlls, the data are present. 
  •  
0 Kudos