Summarize Within tool works inconsistently

12-15-2020 03:28 PM
Labels (2)
Occasional Contributor III

I am creating a web app for non-GIS staff in our organization. I would like to include the Analysis widget with the Summarize Within tool so they'll be able to calculate acreages of one polygon layer within another.

I tested the tool in its first iteration in the morning and it worked great, producing the expected output (I did the same operation in Pro, to verify numbers). Then it just....never worked again. I have attempted to run it multiple times it produces a generic error. [Sub-question: is there a way to view an AGOL tool's geoprocessing history, to find more information about the error?]

I have plenty of credits available, and I have gotten the tool to work one additional time throughout the day on a point layer. But the tool alternates between either processing for years and years, or the generic failure seen below. Status on AGOL has been good all day. 

The calculation....

Screenshot (293).png

The result.... Over and over

Screenshot (296).png

Help would be appreciated. 

0 Kudos
1 Reply
Esri Contributor

Thanks for bringing this issue to our attention. Unfortunately, there isn't currently a way to view the job history for AGOL.
Please contact Esri Support Services ( who will walk through the issue with you so that we are able to reproduce it and work towards developing a solution.


Product Engineer

Product Engineer - Web Analysis
0 Kudos