Initial/Saved Extent not being honored

2774
4
Jump to solution
12-17-2012 11:08 AM
DublinOhio
New Contributor III
Any webmap I open in ArcGIS Online seems to have a different extent (zoomed to full extent) than the last time we saved it. For example http://bit.ly/UgA6TQ - should be zoomed to where the data is. I have even opened, zoomed, saved and next time I open it is back to full extent.

I don't know if this has anything to do with it but we do not use any Esri basemap - we use our own aerial photo as the "base map" in the web map then add our operational layers. All had been fine until this last update.

Thanks,
Brandon
Tags (2)
0 Kudos
1 Solution

Accepted Solutions
MikeMinami
Esri Notable Contributor
This issue will be addressed this week. No changes to your web map should be required. It should just start working.

Thanks,

Mike

View solution in original post

0 Kudos
4 Replies
JorisBak
Esri Contributor
Any webmap I open in ArcGIS Online seems to have a different extent (zoomed to full extent) than the last time we saved it. For example http://bit.ly/UgA6TQ - should be zoomed to where the data is. I have even opened, zoomed, saved and next time I open it is back to full extent.

I don't know if this has anything to do with it but we do not use any Esri basemap - we use our own aerial photo as the "base map" in the web map then add our operational layers. All had been fine until this last update.

Thanks,
Brandon


Yes, we also noticed this. We logged an incident with support today. It seems like an issue in ArcGIS.com map viewer, the app templates and also Flex Viewers load correctly with the saved extent.
0 Kudos
MikeMinami
Esri Notable Contributor
There appears to be a problem saving the extent when the web map has a custom basemap. As a workaround, I did find that if I use the standard Imagery basemap,the extent saved correctly.

A few questions:

Why are you adding the Historic Building Info and Building Information layers separately in your web map? They appear to be part of the Historic District layer already.

I also noticed that the spatial reference of this service

http://maps2.dublin.oh.us/ArcGIS/rest/services/DowntowneApp/MapServer

doesn't match your basemap. For optimum performance, they would match.

Thanks,

Mike
0 Kudos
MikeMinami
Esri Notable Contributor
This issue will be addressed this week. No changes to your web map should be required. It should just start working.

Thanks,

Mike
0 Kudos
JamieRobertson33
New Contributor

Hi Mike,

At Argyll and Bute Council, we use ESRI maps for customers submitting geographic based issues such as Fly Tipping.

Our maps are no longer initially focusing on the street a customer has searched for.  The issues appears to be that initialExtent is not being set.  Is this to do with the issue/fix you are mentioning here?

Thanks,

Jamie Robertson

0 Kudos