Suddenly I can't edit certain fields in attribute tables within a hosted feature service

12-15-2020 04:46 PM
Labels (1)
Occasional Contributor
I unexpectedly can no longer edit fields in a few separate layers (and related tables) on an AGOL Feature Service. I can see the data in the attribute table within the Data tab or in a web map, but can't edit them by double clicking. Other fields are still edible that should be. I can edit all of the fields in Web Map Beta, but this doesn't suite my needs for other reasons. For ones that are in layers and not tables, I can still edit them in the pop-up in a web map, but not in the attribute table. This occurred after I ran a Python script in Jupyter Notebook that updates a number of fields based on an attached text file. This script works as intended, except for this issue. Also, some of the fields that stopped allowing edits aren't even populated by the script. The script does still have the ability to update the non-editable fields. I just can't edit by clicking them in the attribute table.
Here's what I've checked so far:
  1. Editing is enabled in the FS settings (I have also tried disabling and enabling editing)
  2. Editing is checked in the pop-up settings
  3. All replicas have been unregistered (they do still appear as SQLite databases in AGO-Assistant though)
  4. All views have been deleted
  5. The JSON for each layer/table still shows 'editable = True' for the fields in question
  6. All the fields with editing issues have domains, but the existing values are within the domains (at one point though, I did have the script populate the field with a value that wasn't in the domain, but this has been corrected since then)
  7. I tried using Edge rather than Chrome
More about the script: It reads data from a text file attached to a given record and creates a dictionary of variables. The dictionary is used as the data source for a function of the GIS API module. This has worked fine many projects before without this problem.
Since editing the fields in AGOL attribute tables is an important part of my workflow, I would greatly appreciate any ideas for how to fix this issue. Thanks in advance.
0 Kudos
2 Replies
Esri Regular Contributor

Hi @TravisSizemore thanks for the post.

At the recent ArcGIS Online update there was a new capability added to make attribute fields non-editable from the UI. Since you mentioned that in the service definition, the field is still editable I would presume it also shows as editable on the Data > fields > <field> tab. On this tab, does a small pencil icon appear in the Editable section to toggle editing on/off? 

I am not seeing any issues on my end with editing fields that have domains in the attribute table, but we would like to investigate this further through Esri Support. 

At your convenience, would you be able to send me your customer number in a direct message or email to so I can get a case started for you?



0 Kudos
Occasional Contributor


Thanks for the prompt response. I do see the editing setting in the Fields tab and it is still checked as editable. I'll send you an email to open a case.



0 Kudos