Hosted Feature Layer in AGOL: Error Assessing data failed

12-16-2020 11:43 AM
MVP Regular Contributor

I get this error when clicking the attribute table of a hosted feature layer in AGOL.


When I first published this hosted feature layer from Survey 123 Connect everything was fine. If I retrace my steps, here's what I come up with:

1. Original publish of Complaints Survey

2. Submitted 5 surveys so as to have some example points in Complaints feature layer. 

3. Created a webmap (from the Classic Map Viewer, not Beta) and added the Points feature layer. All 5 points are on the map.

4. Created a view

5. Added two new fields to the Complaints table. I did this because Survey 123 requires underscores instead of spaces in the name field values of a multiple choice survey question in the xlsx. The underscores are still there in the published feature layer field values, which I think looks sloppy.

6. My solution is to remove these underscores with a script and put the updated field value in one of the newly added fields. So, I ran the script.

7. I think this is when I noticed the points missing from the webmap with the Complaints feature layer.


I tried these solutions from this help doc even though it references ArcMap and not Pro. No success. And there are a couple similar threads to my problem in GeoNet, but they didn't help.

The things I did were:

1. remove the special character (i.e. &) I had in one field

2. create a new webmap and added the Complaints feature layer

3. deleted the original 5 features

4. added two new features

5. Where there was <Null> in a field I added a value even though this wasn't a problem before.

6. found you do not get the error when viewing the table of a hosted feature layer view

7. found you can see the features in the My Content of the Feature layer

8. you can also see the features in a Dashboard and in Pro


So, basically I can see the features in the table everywhere besides in the feature layer itself when viewing from the Map Viewer.

0 Kudos
0 Replies