"Enrich Layer failed" - any solutions?

02-02-2022 11:06 AM
New Contributor III

Hello! I am trying to use the Enrich Layer tool in ArcGIS Online Map Viewer Classic, and have selected 87 total datasets to enrich a 1 mile buffer from a line segment. I ran this tool about 2 weeks ago with just several variables and it worked. However, every attempt today to enrich the layer with those selected datasets ends up in the tool running for a few seconds and a window appearing that says "Enrich Layer failed". It only estimated it would take 0.87 credits, not sure/don't think credits may be the issue.

I just tried using the tool again, with a subset of variables (10) from 2 categories, as opposed to 87 from 9 categories. And it worked. I'm not sure why.

I am unable to find any helpful posts or solutions that have addressed this issue. Is there a bug? I know there is also the Enrich tool in Pro, that I haven't used before, but it doesn't seem to have the same dataset options to enrich, particularly with Census/ACS data.

If anyone can advise me on this issue, that would be greatly appreciated. Thank you!

0 Kudos
1 Reply
New Contributor II

Hi Tiffany, 

It may be specific to the specific variable. In my situation, I found the 2021 Watch DIY Network Last Week caused the Enrich Layer tool to fail in ArcGIS Pro 2.9.5 Business Analyst.

0 Kudos