Publicly shared dashboard asking for sign-in

1599
12
12-06-2018 09:46 AM
AllenScully
Occasional Contributor II

Likely related to new AGOL just released, but we have a dashboard that is publicly shared (as well as all items in it).  Now when going to it, we get asked to sign in, and that never resolves - sign pop-up appears several times, then goes away and no data is displayed.

Tags (2)
0 Kudos
12 Replies
JakeSkinner
Esri Esteemed Contributor

Hi Allen,

I would start with the Web Map.  Are you able to access this successfully without being prompted to sign-in?  Can you share the web map's URL?

0 Kudos
AllenScully
Occasional Contributor II

Thanks Jake - 

Web Map doesn't ask for a sign in, all data looks to load ok (pay no attention to the Access-Control-Allow-Origin error - that's for the basemap, which is the one thing that will render in dashboard)

Web Map:  https://cotgis.maps.arcgis.com/home/webmap/viewer.html?webmap=25f5dca6f9a8407a9d5f4266868ed266 

Dashboard: Operations Dashboard for ArcGIS 

Allen

JakeSkinner
Esri Esteemed Contributor

The web map prompted me to sign-in.  Do you have any layers from Living Atlas added?

Scott_Harris
Esri Regular Contributor

FYI This layer is not shared:

https://utility.arcgis.com/usrsvcs/servers/e6f021cb0526409a8224baf75aa0aa4c/rest/services/PDSD/Wards... 

I used Fiddler, a web debugging utility, to find out. For that layer, I can see the following response:

{"error":{"code":403,"messageCode":"GWM_0003","message":"You do not have permissions to access this resource or perform this operation.","details":[]}}

MichaelVolz
Esteemed Contributor

Was this opdash working as expected yesterday?  If so, it seems like this error should have occurred yesterday if a layer was not shared correctly.

0 Kudos
AllenScully
Occasional Contributor II

This is strange - That layer shows as shared publicly in AGOL.  It does have security on the map service, but the credentials are stored with the layer when we added it AGOL.  I cannot pinpoint yesterday day as the day this stopped working, but I can confirm that as recently as 3 days ago it was working, and no configuration changes have been made on our end since then.

Forgot to add - no Living Atlas content in this map.

0 Kudos
KatieCullen
Regular Contributor II

Please call Support and open a case if you haven't already.

KellyGerrow
Esri Frequent Contributor

You can also check the history of actions on the item using the history log outlined in this blog

https://community.esri.com/community/gis/web-gis/arcgisonline/blog/2018/09/24/find-events-related-to...‌.

Either way, support is a good place to start looking into this.

-Kelly

0 Kudos
AdriánGhilardi
New Contributor

Hi There, I'm Having the same problema. The map is shareable but not the dashboard. It has No Subscriber Content. 

Not a clue why it can't be shared.

I'll contact support

0 Kudos