Problem uploading CSV file to Hosted Featured Layer

242
2
11-12-2020 05:15 AM
Labels (1)
NordicLeather
New Contributor

Hi, I have created a Hosted Featured Layer (Line Layer)

Then I try to add data to this layer from a *.CSV file (see enlcosed). But always get error message 'No compatible layer found in the transfered file'

What am I doing wrong.

0 Kudos
2 Replies
jherman
New Contributor

Hello,

It appears there's some issues with the format of the CSV. For example, the field names are separated by semicolons instead of commas. When I open it up in Excel, they all appear in one cell. Also, it looks like most values are separated by semicolons instead of commas.

Thanks,
Josh

0 Kudos
NordicLeather
New Contributor

Many thanks for your answer!

Yes you're right - seems to be some problem with CSV file.

But I have tried another way to work around and import the Excel file, but same Error.

1. Have created a 'blank' Line Layer, and then the Fields: 

OBJECTIDGlobalIDShape__LengthCreationDateCreatorEditDateEditor

automaticaly are created.

2. Open this new empty Featured Layer and chooses Update data - Add data to layer

3. Choose 'Line_layer_test.xlsx* (see attached) and press 'Transfer and continue'

4. Get the same Error message 'Error no compatible layer found in transfered file'

Cant understand this. I'm very grateful for any help!

 

0 Kudos