Print widget errors

815
9
03-27-2019 09:27 AM
RalphBradt1
New Contributor II

When printing out of a web app using the print widget, I most often get the error "Unable to load //utility.arcgisonline.com/arcgis/rest/services/Utilities/Printing/Tools/GPServer/Export%20Web%20Map%20Task/execute status: 0". I can occasionally get a few prints, but  then consistently get the error. I can reboot my machine and sometimes get a few more prints, but not consistently. This is happening using Chrome, Firefox, or IE and, further, I'm getting it happening on two different machines. It also happens with similar, but different, web apps.I'm totally at a loss to figure out what's going on here.

0 Kudos
9 Replies
KellyGerrow
Esri Frequent Contributor

Can you share your application or web map? If not, try to get in touch with tech support.

-Kelly

0 Kudos
RalphBradt1
New Contributor II

The app is at: https://melc.maps.arcgis.com/apps/webappviewer/index.html?id=1ba88b34779a44ffba353a41c2df1942

I have since gotten it to print once at 50 dpi, but I'm shooting for 300 dpi, which I have gotten, but only on occasion

0 Kudos
KellyGerrow
Esri Frequent Contributor

Thanks Ralph,

Some optimizations have been made to help the widget load faster, but we are still seeing intermittent failures to generate the pdf. This could be due to the size of the data being input or a variety of other factors. For that reason I'd like you to get in touch with Tech support to look into the issue further.

Please let us know if you need help getting in touch with support.

-Kelly

0 Kudos
RalphBradt1
New Contributor II

It is kind of a funny deal. I have managed to get some maps to print out (hit and miss) but some refuse entirely. Some appear to have printed, but the PDFs have badly broken fonts. Is there a specific facet of support I need to contact?

0 Kudos
KellyGerrow
Esri Frequent Contributor

Get in touch with support using the contact information for the country you live in:

https://support.esri.com/en/contact-tech-support

Mention that you are using Web AppBuilder in ArcGIS Online and are having printing issues. They should get you to the right person.

-Kelly

0 Kudos
RalphBradt1
New Contributor II

Thank, Kelly! I'll do that.

0 Kudos
ClaudiaGIS
New Contributor III

I am using the print widget and it seems to work out well. But if I download the PDF then I get an error message saying the font is not found. It seems it happens when you try to get a map using a larger extent than the default. Is there a chance someone can please help me.

0 Kudos
City_of_Edgewater__Fl_GIS_Div_
New Contributor III

I'm getting something like that too, how do we fix this

0 Kudos
ClaudiaGIS
New Contributor III

What I see it has to do with the scale. If you create a layer with the whole zoom extent it helps. I know it is not a real solution but is kind of a workaround. I am looking at other option for printing. If you find a solution please let me know. Stay safe.

0 Kudos