Select to view content in your preferred language

Publish Streaming Service Button Grayed Out in GeoEvent Server 11.0

1138
9
Jump to solution
11-17-2022 08:07 AM
MichaelKastanotis
New Contributor II

I am trying to publish a Streaming GeoEvent Service on a fresh deployment of GeoEvent Server 11.0

The Publish Streaming Service is grayed out. My understanding is that I need to use the Default server and the Root folder. I must be missing something in the site configuration?

0 Kudos
1 Solution

Accepted Solutions
MichaelKastanotis
New Contributor II

Working with Esri support revealed that the GeoEvent Server machine needs to be authorized for both ArcGIS GeoEvent Server and ArcGIS GIS Server.

View solution in original post

9 Replies
JohnLucotch2
Occasional Contributor

Anybody figure this out?  

 

0 Kudos
MichaelKastanotis
New Contributor II

Working with Esri support revealed that the GeoEvent Server machine needs to be authorized for both ArcGIS GeoEvent Server and ArcGIS GIS Server.

JohnLucotch2
Occasional Contributor
Great thanks so much!!

0 Kudos
JosephSia2
New Contributor III

Looks like the answer i'm seeking.

I thought it was already authorized because Geoevents is running.

Would you have any links I could refer to for authorizing both? Thank you.

0 Kudos
Kiran_Rupali
New Contributor II

were you able to resolve this issue? I am seeing the same problem in 11.1

0 Kudos
GarrettMelvin
New Contributor III

We recently upgraded from 10.9.1 to 11.1 and are experiencing the same issue.  We tried authorizing the server as GeoEvent Server, as well as authorizing as ArcGIS Server and GeoEvent Server, but that did not remedy the issue.  Our existing stream services published from 10.9.1. fail to start, we get the error message "Service failed to start" "This ArcMap based service cannot be started because the ArcMap Runtime Support feature is not installed."  Currently working with ESRI support to find a solution.  

 

GarrettMelvin_0-1686841971082.png

 

0 Kudos
GarrettMelvin
New Contributor III

It turns out in the upgrade our credentials were lost in the Default data store connection.  Supplying the credentials remedied the issue.  

0 Kudos
JohnLucotch2
Occasional Contributor

Yes you need to authorize GeoEvent Server with both ArcGIS Server and GeoEvent Server.

0 Kudos
Kiran_Rupali
New Contributor II

thanks for the quick response. do you have steps on how to do that?

 

0 Kudos