Geoevent server 10.7.1 No service was found

315
4
12-16-2020 10:16 PM
Hwa_SaupLee
New Contributor III

Geoevnt server has been running over year without problem but last week I got "No service was found" in accessing the geoevent manager.   

I did following steps but so far no luch:

  • I reboot the server
  • restart services: arcgis server, geoevent gateway, geoenvet server
  • restart zookeeper service (synchronization service)
  • remove content in the geoevent/data

but not working so far.   Any suggestion?  

Tags (2)
0 Kudos
4 Replies
DominicRoberge2
New Contributor III

I have the same problem and using arcgis server and Geoevent 10.8. I have been working for two weeks with Tech Support on that and nothing is working. We did an ADMIN reset, and no matter what the Zookeeper status us always UNKNOWN. I also tried to restore the machine backup from the day prior and STILL get the "NO SERVICE WAS FOUND". I guess the last option will be a clean re-install???

0 Kudos
Hwa_SaupLee
New Contributor III

hmm.  waiting for tech support call.  it is a production server and  I want to avoid reinstall or factory reset.  let you know how it goes.  

0 Kudos
Hwa_SaupLee
New Contributor III

I followed the steps in this document: HowTo:  Administratively Reset GeoEvent Server (10.5.x / 10.6.x) (https://community.esri.com/t5/arcgis-geoevent-server-blog/howto-administratively-reset-geoevent-serv...  The steps for 10.6.x works for my case (10.7.1).

Then the geoevent server manager is accessible but all services are gone because the steps delete all service configurations.     It is important to back up the configuration before you follow the step.  Geoevent services are restored by configuration import and all services are back to normal. 

0 Kudos
Stefan_Jung
Esri Contributor

GeoEvent automatically backups the configuration file. Default Location is: C:\ProgramData\Esri\GeoEvent (this is also mentioned in the Blog Post). You can also configure GeoEvent to save the automatic backups to other locations (defined at Site > Data Stores | Registered folders > Automatic Backups).

If you dont have the option to create a backup before resetting this might help.

Best,

Stefan

0 Kudos