Select to view content in your preferred language

Latest ARCGIS for PowerBI update is bug ridden and not useable

4157
16
10-06-2021 03:51 AM
PeterMau
New Contributor

Hi,

Every since the latest ARCGIS update for PowerBI released within the last month, I've been plagued by a myriad of bugs which make is unusable for any practical use in reporting.

FYI Currently running PowerBI 2.97.921.0 64-bit (September 2021), I have also cleared my caches in the options menu>data load area as I've seen some potential someone else on the form saying this may be a solution.

First issue and probably most significant is that the map will forget settings you've selected.

This covers the location type page:

PeterMau_1-1633515650415.png

  • if I interact with slicers on the report to change the postcodes shown on the map, the matching will switch from exact match to closest, and will sometimes even switch from showing boundaries to points!
  • it then plagues me with this warning to switch the accuracy back to exact match!
  • PeterMau_4-1633516913317.png

     

Also impacts the symbology page

  • again, filtering with the slicer can cause the colour ramp to not update properly (postcodes being shaded as other despite having a valid value)
  • the colour ramp scale can reverse 
  • the colour ramp can reset entirely back to the default orange colours
  • the method selected can default to natural break, even if I've selected equal interval
  • symbol style can rest - if I set it up as have black semi-transparent borders it can reset back to white borders at 100% opacity

The newly added labels feature also can reset and disappear upon filtering with the slicer.

The tooltip doesn't carry over formatting set to measures in PowerBI (i.e percentages are shown as decimal numbers):

PeterMau_2-1633516536697.png

PeterMau_3-1633516549691.png

Should note also that refreshing the powerbi workbook can cause all the issues listed above to occur.

Is it at all possible to roll back this update, or at the very least have a different branch of the arcgis maps where you can use the legacy version on PowerBI?  This update renders a bunch of our key reports useless.

Happy to hear back any updates.

 

I do have an example PowerBI workbook set up which i've managed to recreate the above issues with - I'm happy to share it but the forum won't allow me to upload powerbi files to posts.

Again, I'm happy to email across should a support rep need it.

 

 

 

 

 

16 Replies
by Anonymous User
Not applicable

@DouglasKnabe It looks like we have this fixed in the next release that we're handing off this week. It should be live soon and we'll post more as soon as we know when it will land. I would conservatively estimate December 1st but we're hoping it will be faster. 

The visual we build deploys independent of the monthly Power BI releases.

by Anonymous User
Not applicable

The update was handed off, now its just a matter of time for it to push through production. Hopefully we'll see it on the 1st but it may delay until the 8th. 

We're very eager to get this update out to everyone!

0 Kudos
KyleEnger
New Contributor

Hi, what's the status on this? I'm continuing to have issues similar to PeterMau, i.e., map symbology resetting for no clear reason. I'm also having trouble determining which version of ArcGIS Maps for Power BI is installed. Is there a way to install older versions?

0 Kudos
KevinSorg
New Contributor

Hi 

Facing the exactly same issue as specified by PeterMau. 

When will this be solved? 

Thanks 

Kevin

0 Kudos
PrinceMarambo
New Contributor

I am also experiencing these bugs still and the maps are now pretty unfunctional on all the reports. When is the correct update with bugs fixed going to be coming?

0 Kudos
by Anonymous User
Not applicable
0 Kudos
DavidLeitson
New Contributor

Hello, any update on this? I'm sill having the same issue with ArcGIS for PowerBI. If I interact with slicers on the report to change the map, the matching will switch from exact match to closest. It also impacts the symbology page such that it reverts to the default setting. 

0 Kudos